Bug 352511 - return of an avc on useradd with livecd user
return of an avc on useradd with livecd user
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks: F8Blocker
  Show dependency treegraph
 
Reported: 2007-10-25 11:24 EDT by Jeremy Katz
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-28 14:04:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeremy Katz 2007-10-25 11:24:19 EDT
The live images have started getting denials when adding their user again.
   allow useradd_t unconfined_gnome_home_dir_t:dir create

Did we change the context for ~/.gnome ?
Comment 1 Daniel Walsh 2007-10-25 13:33:15 EDT
Which policy are you using?

Works for me at selinux-policy-3.0.8-32.fc8
Comment 2 Jeremy Katz 2007-10-25 13:50:47 EDT
This is today's rawhide with -32. 
Comment 3 Daniel Walsh 2007-10-25 14:06:41 EDT
It should be creating this file as    

unconfined_gnome_home_t

What did it label the rest of the files?  
Comment 4 Jeremy Katz 2007-10-25 14:33:54 EDT
~/.bash_logout got unconfined_home_t

The rest of the files in /etc/skel didn't get copied since useradd stops on the
failure.  And this error started showing up with rawhide live images of
yesterday.  20071023 is fine, 20071024 breaks
Comment 5 Jeremy Katz 2007-10-25 15:51:59 EDT
Should be fixed with selinux-policy -33.  Live images tomorrow will confirm
Comment 6 Jeremy Katz 2007-10-28 14:04:15 EDT
Fix confirmed with live images of rawhide-20071028

Note You need to log in before you can comment on or make changes to this bug.