Bug 352521 - sysreport issues sysrq-t by default - this is dangerous
sysreport issues sysrq-t by default - this is dangerous
Status: CLOSED DUPLICATE of bug 232920
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: sos (Show other bugs)
5.0
All Linux
high Severity urgent
: ---
: ---
Assigned To: Navid Sheikhol-Eslami
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-25 11:42 EDT by Sam Folk-Williams
Modified: 2007-12-27 08:25 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-27 08:25:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sam Folk-Williams 2007-10-25 11:42:57 EDT
+++ This bug was initially created as a clone of Bug #348981 +++

Description of problem:

Sysreport in HREL 5.0 issues sysrq-t by default
Version-Release number of selected component (if applicable):


How reproducible:

Always
Steps to Reproduce:
1. Run sysreport command with no options
2.
3.
  
Actual results:

Sysreport runs and echos "t" to /proc/sysrq-trigger and other sysrq commands

Expected results:

Sysrq-t should not be issued by default
Additional info:

This went in as a feature but it's really a regression. Issuing sysrq should
only be done in specific circumstances. It should not be done as a routine
practice when sysreport is normally run. Sysrq-t can cause a large variety of
problems including applicaiton failover, scsi resets/timeouts, bonding failover,
and application hangs.

-- Additional comment from than@redhat.com on 2007-10-24 04:55 EST --
it seems a critical bug. We should probably release the fix.

-- Additional comment from pknirsch@redhat.com on 2007-10-24 06:37 EST --
Suggesting for RHEL-3.9 and giving Devel ACK as the fix is simple and important.

Read ya, Phil

-- Additional comment from rbiba@redhat.com on 2007-10-25 11:37 EST --
QA ACK for RHEL 3.
Comment 1 Sam Folk-Williams 2007-10-25 12:31:36 EDT
I think this is actually sysreport not sos
Comment 2 Sam Folk-Williams 2007-10-26 08:23:19 EDT
Actually I think this is a dup of bug 232920
Comment 3 Navid Sheikhol-Eslami 2007-12-27 08:25:22 EST

*** This bug has been marked as a duplicate of 232920 ***

Note You need to log in before you can comment on or make changes to this bug.