Bug 35255 - bad compilation configuration for nut (qa0404)
Summary: bad compilation configuration for nut (qa0404)
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: nut   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-04-08 22:34 UTC by Michal Jaegermann
Modified: 2007-04-18 16:32 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-13 20:29:03 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Michal Jaegermann 2001-04-08 22:34:17 UTC
Programs from 'nut' package are configured and compiled to use
'nogroup' group id.  There is no such group and 'service nut start'
fails due to this.

   Michal
   michal@harddata.com

Comment 1 Ngo Than 2001-04-13 19:31:45 UTC
It's compiled with --with-uid=`id -u nobody` --with-gid=`id -g nobody`

i think, you have wrong id for nobody.

Comment 2 Michal Jaegermann 2001-04-13 20:28:58 UTC
# rpm -qf /usr/bin/bestups
nut-0.44.1-5
# strings /usr/bin/bestups | grep nog
nogroup

and a daemon complaints on a startup about missing 'nogroup' gid.

It is quite possible that a configuration and/or compilation of the
whole thing is buggy but this what this report was about.

Comment 3 Ngo Than 2001-04-19 10:00:09 UTC
it's fixed in nut-0.44.3-1.


Note You need to log in before you can comment on or make changes to this bug.