Bug 352581 - GFS2: implement gfs2_tool lockdump
GFS2: implement gfs2_tool lockdump
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: gfs2-utils (Show other bugs)
5.1
All Linux
low Severity low
: ---
: ---
Assigned To: Chris Feist
GFS Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-25 11:56 EDT by Robert Peterson
Modified: 2010-01-11 22:40 EST (History)
0 users

See Also:
Fixed In Version: RHBA-2008-0350
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 13:20:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to implement gfs2_tool lockdump (3.72 KB, patch)
2007-11-06 19:05 EST, Robert Peterson
no flags Details | Diff

  None (edit)
Description Robert Peterson 2007-10-25 11:56:21 EDT
Description of problem:
Long ago, we decided we needed to implement a function in GFS2
to replace the missing gfs2_tool lockdump.  We used bug #228540
to make the necessary changes to the gfs2 kernel code.  It makes
the glock information available to userland through the debugfs.

At that time, I implemented a userland patch to gfs2_tool that
used the new debugfs feature.  See comment #10 of bug 228540:
https://bugzilla.redhat.com/attachment.cgi?id=149854

There was a comment in bugzilla stating that we should do the
userland portion of the fix, but apparently it was never done.
I thought I shipped the userland portion, but apparently not;
the code isn't there.  This is so that users don't have to mess
around with debugfs; gfs2_tool will do it for you.

The patch mentioned above isn't complete because the design of
228540 changed slightly.  The glock information in debugfs is now
one subdirectory level deeper I think.  Still, it should be a
cakewalk (< 1 hour) to implement, test and commit given the above
patch.  Well, maybe we should also make sure it has safeguards in
case debugfs isn't compiled into the kernel (which it always is in
RHEL, but not guaranteed in upstream) so call it 2 hours.

Version-Release number of selected component (if applicable):
RHEL5.1

How reproducible:
Always

Steps to Reproduce:
gfs2_tool lockdump
  
Actual results:
gfs2_tool: lockdump not implemented

Expected results:
It should make use of the debugfs information.

Additional info:
Comment 1 Robert Peterson 2007-11-06 19:05:10 EST
Created attachment 249781 [details]
Patch to implement gfs2_tool lockdump

I found several minor problems with the previously mentioned patch.
This version fixes all that up.  I've tested it thoroughly on roth-01.
Comment 2 Robert Peterson 2007-11-06 19:17:50 EST
Requesting ack flags so we can get this into RHEL5.2.
Patch is in-hand and well tested.

Today the users can do the gfs2 glock dump simply by catting the
appropriate file in debugfs.  However, from past implementations, they
are used to doing "gfs_tool lockdump".  Therefore this implements that
feature which simply finds and dumps the file for them.  That makes
RHEL5 more user-friendly from their perspective.
Comment 3 RHEL Product and Program Management 2007-11-06 19:25:02 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 4 Robert Peterson 2007-11-07 10:01:16 EST
Fix tested on roth-01 and committed to CVS at HEAD and RHEL5 branches
for inclusion in RHEL5.2.  Changing status to modified.
Comment 7 errata-xmlrpc 2008-05-21 13:20:20 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0350.html

Note You need to log in before you can comment on or make changes to this bug.