Bug 352681 - SELinux problems from hal_lpadmin running hp-info
SELinux problems from hal_lpadmin running hp-info
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: hal-cups-utils (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F8Target
  Show dependency treegraph
 
Reported: 2007-10-25 12:38 EDT by Tim Waugh
Modified: 2008-02-12 09:23 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-12 09:23:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tim Waugh 2007-10-25 12:38:06 EDT
Description of problem:
When unplugging or switching off a USB printer, SELinux AVC messages are
generated.  This seems to be to do with hal_lpadmin executing hp-info when the
'remove' function is called.

Version-Release number of selected component (if applicable):
hal-cups-utils-0.6.13-1.fc8
selinux-policy-3.0.8-32.fc8

How reproducible:
100%

Steps to Reproduce:
1.Remove all print queues.
2.Switch on connected USB printer.
3.Switch off USB printer or disconnect it.
  
Actual results:
AVC messages.
Comment 1 Tim Waugh 2008-02-12 09:23:24 EST
This is no longer a problem for Fedora 9, and has been worked around in Fedora 8
by de-activating the printer-disabling code.

Note You need to log in before you can comment on or make changes to this bug.