Bug 352811 - Support for newer Wacom Serial Devices. WACF007 WACF008
Support for newer Wacom Serial Devices. WACF007 WACF008
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-25 13:23 EDT by Arlinton Bourne
Modified: 2007-12-06 19:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-06 19:12:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch for 8250_pnp.c to add support for the WACF007 & WACF008 (557 bytes, patch)
2007-10-25 13:23 EDT, Arlinton Bourne
no flags Details | Diff
Udev rules for a WACF008 Device (547 bytes, text/plain)
2007-10-25 13:25 EDT, Arlinton Bourne
no flags Details

  None (edit)
Description Arlinton Bourne 2007-10-25 13:23:19 EDT
Description of problem:
Our serial driver doesn't pick up the newer Wacom Serial (pnp) device. It
doesn't, by default, link actual device to anything in /dev (in particular
/dev/ttyS0)

The work around is to use the setserial program to configure /dev/ttyS0 to point
to the device.

There's a patch upstream to prevent this work around and looks like it is slated
for 2.6.24 (it's in Linus's tree)

I've attached and tested the patch and wrote a udev rule to "Do the Right Thing".

Hope it helps...
Comment 1 Arlinton Bourne 2007-10-25 13:23:19 EDT
Created attachment 237691 [details]
Patch for 8250_pnp.c to add support for the WACF007 & WACF008
Comment 2 Arlinton Bourne 2007-10-25 13:25:21 EDT
Created attachment 237701 [details]
Udev rules for a WACF008 Device

Here's the udev rule it needs work though.
Comment 3 Chuck Ebbert 2007-10-25 15:32:02 EDT
(In reply to comment #1)
> Created an attachment (id=237691) [edit]
> Patch for 8250_pnp.c to add support for the WACF007 & WACF008
> 

This is already in 2.6.24-rc1
Comment 4 Chuck Ebbert 2007-12-06 19:12:24 EST
Fixed went in F8 kernel on 10/25

Note You need to log in before you can comment on or make changes to this bug.