Bug 352941 - KMail does not automatically decrypt multipart/encrypted messages
KMail does not automatically decrypt multipart/encrypted messages
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kdepim (Show other bugs)
7
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-25 14:17 EDT by Adalbert Prokop
Modified: 2007-12-12 14:57 EST (History)
1 user (show)

See Also:
Fixed In Version: 3.5.8-10.svn20071129.ent.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-12 14:57:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 151373 None None None Never

  None (edit)
Description Adalbert Prokop 2007-10-25 14:17:28 EDT
Description of problem:

KMail 1.9.6 (kdepim-3.5.7-10.svn20070926.ent.fc7) does not automatically decrypt
multipart/encrypted GPG messages any more. It worked until today's update.
If the mime type is multipart/mixed, then the KMail behaves correctly, asks for
password and decrypts the message.

Version-Release number of selected component (if applicable):
kdepim-3.5.7-10.svn20070926.ent.fc7

Steps to Reproduce:
1. Create a new message and set the encoding type to OpenPGP/MIME.
2. Choose "Send later"
3. Look at the message in your outgoing folder

Actual results:
I'm shown a message that this message is encrypted and no decription is
possible. I can click on "Decrypt Message" in which case I'm asked for password
and the message is being decrypted and shown.

Expected results:
KMail should ask for password atomatically, no matter what kind of envelope is
chosen for the message.

Additional info:
I'm using gpg-agent and pinentry-qt for password provision to GPG.
Comment 1 Rex Dieter 2007-10-25 14:21:24 EDT
This one would be a good one to report upstream to
http://bugs.kde.org/
to get upstream-dev attention.
Comment 2 Adalbert Prokop 2007-10-26 16:00:08 EDT
I've now reported this bug on KDE's bug tracking system:
http://bugs.kde.org/show_bug.cgi?id=151373
Comment 3 Rex Dieter 2007-10-26 18:48:56 EDT
Thanks.
Comment 4 Rex Dieter 2007-11-29 21:57:48 EST
Can you try out this test build:
http://koji.fedoraproject.org/koji/buildinfo?buildID=26172
Comment 5 Fedora Update System 2007-12-03 06:46:40 EST
kdepim-3.5.8-10.svn20071129.ent.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kdepim'
Comment 6 Adalbert Prokop 2007-12-03 15:58:03 EST
Seems to be all right in KMail 1.9.6 enterprise 0.20071012.724442 (KDE
3.5.8-7.fc7). I suppose I missed the right checkbox in KMail's config - or it
was not there previously.
Comment 7 Fedora Update System 2007-12-12 14:57:45 EST
kdepim-3.5.8-10.svn20071129.ent.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.