Bug 353021 - fc8t3 installation exited abnormally on x445
fc8t3 installation exited abnormally on x445
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: rhpxl (Show other bugs)
8
ia32e All
low Severity urgent
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
ARRAY(0x8bcb30)
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-25 15:06 EDT by IBM Bug Proxy
Modified: 2008-03-28 10:24 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-12 16:22:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
clt+alt+f4 (83.32 KB, image/jpeg)
2007-10-25 15:06 EDT, IBM Bug Proxy
no flags Details
A more general patch (527 bytes, text/plain)
2007-10-25 15:06 EDT, IBM Bug Proxy
no flags Details
anaconda-error (55.83 KB, image/jpeg)
2007-10-25 15:06 EDT, IBM Bug Proxy
no flags Details
clt+alt+f3 (79.01 KB, image/jpeg)
2007-10-25 15:06 EDT, IBM Bug Proxy
no flags Details
X.log got just after stage2 start (55.77 KB, text/plain)
2007-10-25 15:06 EDT, IBM Bug Proxy
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
IBM Linux Technology Center 39809 None None None Never

  None (edit)
Description IBM Bug Proxy 2007-10-25 15:06:16 EDT
Installation of fedoracore8 test3 abnormally exited after selecting Installation
methods(NFS/Hard-drive) and before starting the Anaconda installer by throwing a
error "TypeError: Expected a string, install exited abnormally [1/1]", I am
attaching screenshot. 

------Hardware Environment------
    Machine type : x445
    Cpu type :IA-32
    Is this reproducible? Yes

-----Describe the steps:----------
     1. Boot with fedora core 8 test3(boot.iso) present in images/boot.iso of DVD.
     2. After booting up, select language, country,then.. Installation method.
     3. I tried with NFS and Hard-driver options.
     4. After giving the path and ip of nfs, it shows anaconda starting....and 
        suddenly encounters the error.
  
  
I verified this bug on x335a and confirmed that its a "machine dependent" by
installing fc8t3 images on x335a successfully.I used the anaconda installer
resides at isolinux/vmlinuz isolinux/initrd.img for booting up and installed
using NFS server.It worked fine.

There were a function with is returning not a string value where it was expected.
Comment 1 IBM Bug Proxy 2007-10-25 15:06:19 EDT
Created attachment 237801 [details]
clt+alt+f4
Comment 2 IBM Bug Proxy 2007-10-25 15:06:21 EDT
Created attachment 237811 [details]
A more general patch
Comment 3 IBM Bug Proxy 2007-10-25 15:06:23 EDT
Created attachment 237821 [details]
anaconda-error
Comment 4 IBM Bug Proxy 2007-10-25 15:06:24 EDT
Created attachment 237831 [details]
clt+alt+f3
Comment 5 IBM Bug Proxy 2007-10-25 15:06:26 EDT
Created attachment 237841 [details]
X.log got just after stage2 start
Comment 6 IBM Bug Proxy 2007-10-25 15:21:05 EDT
------- Comment From brenohl@br.ibm.com 2007-10-25 15:18 EDT-------
https://bugzilla.redhat.com/show_bug.cgi?id=353021
Comment 7 IBM Bug Proxy 2007-11-14 07:25:53 EST
------- Comment From brenohl@br.ibm.com 2007-11-14 07:24 EDT-------
Hi Red Hat,
Did you have a chance to take a look on this problem?

Thanks
Comment 8 IBM Bug Proxy 2007-11-28 06:55:57 EST
------- Comment From mohd.omar@in.ibm.com 2007-11-28 06:51 EDT-------
Hi Redhat,

I verified this bug against FC8GA on x445 machine. I am able to reproduce this
bug. I think patch has not been picked up for FC8GA release.

--thanks
omar
Comment 9 IBM Bug Proxy 2007-12-13 10:41:18 EST
------- Comment From joseferr@br.ibm.com 2007-12-13 10:38 EDT-------
Hello Red Hat,

Have you had the chance to check for this issue? F8 GA ISO has trouble with this
machines. Any chance we will be able to include this patch to anaconda?

Thank you.
Comment 10 IBM Bug Proxy 2007-12-26 13:16:11 EST
------- Comment From joseferr@br.ibm.com 2007-12-26 13:10 EDT-------
Red Hat,

Any news about this issue. Thanks.
Comment 11 IBM Bug Proxy 2008-01-28 11:41:01 EST
------- Comment From joseferr@br.ibm.com 2008-01-28 11:36 EDT-------
Adam,

It's been over 3 months we opened this bug against Fedora 8 and provided a patch
for the issue (quite simple really, but still blocking the install).
As the current schedule for Fedora 9, we would like to know if this correction
will be in the alpha or any subsequent release? We sure would like this to be
available for Fedora 9.

Thank you.

PS: the bug is set to "low priority" but "urgent severity", which makes me a bit
confused.
Comment 12 Adam Jackson 2008-02-12 16:22:12 EST
Built as rhpxl 0.49-4.fc9, thanks!
Comment 13 IBM Bug Proxy 2008-02-13 09:26:24 EST
------- Comment From mohd.omar@in.ibm.com 2008-02-13 09:17 EDT-------
I am able to reproduce the problem in F9Alpha.
Comment 14 IBM Bug Proxy 2008-03-28 10:24:58 EDT
------- Comment From mohd.omar@in.ibm.com 2008-03-28 10:22 EDT-------
F9 Beta worked fine on x445 with graphical installation.I am closing this bug now.

--thanks all for your support.
Omar M

Note You need to log in before you can comment on or make changes to this bug.