Bug 353161 - remove /usr from $PATH at install
remove /usr from $PATH at install
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-25 16:01 EDT by John Reiser
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-25 22:15:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Reiser 2007-10-25 16:01:03 EDT
Description of problem: 1% of all system calls during an install are to lookup
filenames in /usr/... that cannot exist because there is no /usr.


Version-Release number of selected component (if applicable):
anaconda-11.3.0.45-1


How reproducible: always


Steps to Reproduce:
1. as soon as vtty2 becomes available:
strace -f -o '|gzip' -p <pid-of-anaconda>  > strace.out &
(you have to provide strace on a USB flash memory device before boot, and mount
the device yourself.)
2. look at strace.out (63MB compressed, 1GB uncompressed) for ENOENT
3.
  
Actual results:
13,238,719  system calls
   467,222  ENOENT
   134,782  "/usr/..." {==> ENOENT]


Expected results: very few lookups involving "/usr/...:


Additional info:
Comment 1 John Reiser 2007-10-25 16:42:24 EDT
Also set LD_LIBRARY_PATH explicitly if not already set.  The default is to have
LD_LIBRARY_PATH unset in the shell environment, which causes ld-linux.so.2 to
use "/lib:/usr/lib".
Comment 2 John Reiser 2007-10-25 22:15:59 EDT
I forgot about chroot("/mnt/sysimage").  Instead of a general problem, there may
only be special cases.

Note You need to log in before you can comment on or make changes to this bug.