Bug 353321 - rpmlint problems with xguest.spec
rpmlint problems with xguest.spec
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: rpmlint (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Ville Skyttä
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-25 17:36 EDT by Daniel Walsh
Modified: 2008-03-07 13:14 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-07 13:14:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
xguest.spec (2.00 KB, text/x-rpm-spec)
2007-10-25 17:36 EDT, Daniel Walsh
no flags Details

  None (edit)
Description Daniel Walsh 2007-10-25 17:36:48 EDT
Description of problem:

Ran this against a package build to xguest.spec, it gives me several
questionable errors.

rpmlint ~/sources/RPMS/noarch/xguest-1.0.2-1.fc8.noarch.rpm 
xguest.noarch: E: use-tmp-in-%post
xguest.noarch: E: use-of-home-in-%post
I don't think there is any problem with the way I am using /tmp or $HOME in the
spec file
xguest.noarch: W: uncompressed-zip /etc/desktop-profiles/xguest.zip
- This is the format saboyon wants, I guess we could open a bug against sabayon.
Comment 1 Daniel Walsh 2007-10-25 17:36:48 EDT
Created attachment 238111 [details]
xguest.spec
Comment 2 Ville Skyttä 2007-10-25 18:07:43 EDT
Usage of /tmp and $HOME looks legitimate in this case indeed assuming there's no
*.d dir that could be used to drop regular files into instead of doing it in
scriptlets.  But we certainly do want to note uses of $HOME in scriptlets in
general, and perhaps /tmp too although there are more valid use cases for it
than $HOME.  Apart from maybe downgrading use-of-tmp to a warning, I don't have
good ideas how to improve rpmlint about these cases, do you?

uncompressed-zip is pretty much cosmetic and I have no idea whether quicker
unpacking would be more important than space savings in this case (nor whether
any of those are actually measurable here), but somehow it sounds strange to me
that if something operates on zip files, it wouldn't support compressed ones.
Comment 3 Ville Skyttä 2008-03-07 13:14:34 EST
Closing due to lack of feedback in almost 5 months, please feel free to reopen
if you can help with the questions in comment 2.

Note You need to log in before you can comment on or make changes to this bug.