Bug 353451 - stuck grab
stuck grab
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
bzcl34nup
:
: 453926 (view as bug list)
Depends On:
Blocks: F10Preview 465154
  Show dependency treegraph
 
Reported: 2007-10-25 21:23 EDT by Bill Nottingham
Modified: 2014-03-16 23:11 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-28 07:57:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2007-10-25 21:23:20 EDT
Description of problem:

While I had the left-click menu open for nm-applet, the 'Enter the password to
unlock your keyring' dialog popped up - I was then unable to either focus to
dismiss the menu, or focus the entry of the dialog to enter the passphrase.

Switching to a VT and killing nm-applet unstuck things.

Version-Release number of selected component (if applicable):

NetworkManager-0.7.0-0.3.svn3020.fc8
gnome-keyring-2.20.1-3.fc8
Comment 1 Warren Togami 2007-10-25 23:54:53 EDT
notting, are you running compiz?

In my experience, the dialog is indeed grabbing, but also compiz is improperly
layering the windows, making it impossible to type into the dialog.
Comment 2 Bill Nottingham 2007-10-26 11:34:26 EDT
No, not running compiz.
Comment 3 Charles R. Anderson 2007-10-29 13:05:06 EDT
Running compiz here, same problem.

NetworkManager-0.7.0-0.5.svn3030.fc8
gnome-keyring-2.20.1-3.fc8
compiz-0.6.2-2.fc8
Comment 4 Bug Zapper 2008-04-04 10:17:24 EDT
Based on the date this bug was created, it appears to have been reported
during the development of Fedora 8. In order to refocus our efforts as
a project we are changing the version of this bug to '8'.

If this bug still exists in rawhide, please change the version back to
rawhide.
(If you're unable to change the bug's version, add a comment to the bug
and someone will change it for you.)

Thanks for your help and we apologize for the interruption.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.
Comment 5 Zack Cerza 2008-10-01 16:19:56 EDT
Still in rawhide, but killing either nm-applet or metacity did not help. I had to kill X. Data loss -> high severity.

metacity-2.23.610-1.fc10.x86_64
NetworkManager-0.7.0-0.11.svn4022.2.fc10.x86_64
Comment 6 Matthias Clasen 2008-10-08 14:23:18 EDT
Fix up blocker deps
Comment 7 John Poelstra 2008-10-10 18:21:01 EDT
This bug has been triaged
Comment 8 Dan Williams 2008-10-17 12:07:20 EDT
*** Bug 453926 has been marked as a duplicate of this bug. ***
Comment 9 Dan Williams 2008-10-27 23:19:20 EDT
applet svn r986
Comment 10 Dan Williams 2008-10-28 07:57:26 EDT
Built in http://koji.fedoraproject.org/koji/taskinfo?taskID=908445 (	NetworkManager-0.7.0-0.11.svn4229.fc10)
Comment 11 Fedora Update System 2008-11-23 18:05:33 EST
NetworkManager-0.7.0-0.12.svn4326.fc9,NetworkManager-vpnc-0.7.0-0.11.svn4326.fc9,NetworkManager-openvpn-0.7.0-16.svn4326.fc9,NetworkManager-pptp-0.7.0-0.12.svn4326.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/NetworkManager-0.7.0-0.12.svn4326.fc9,NetworkManager-vpnc-0.7.0-0.11.svn4326.fc9,NetworkManager-openvpn-0.7.0-16.svn4326.fc9,NetworkManager-pptp-0.7.0-0.12.svn4326.fc9
Comment 12 Fedora Update System 2008-11-23 18:07:24 EST
NetworkManager-0.7.0-0.12.svn4326.fc8,NetworkManager-vpnc-0.7.0-0.11.svn4326.fc8,NetworkManager-openvpn-0.7.0-16.svn4326.fc8,NetworkManager-pptp-0.7.0-0.12.svn4326.fc8 has been submitted as an update for Fedora 8.
http://admin.fedoraproject.org/updates/NetworkManager-0.7.0-0.12.svn4326.fc8,NetworkManager-vpnc-0.7.0-0.11.svn4326.fc8,NetworkManager-openvpn-0.7.0-16.svn4326.fc8,NetworkManager-pptp-0.7.0-0.12.svn4326.fc8
Comment 13 Fedora Update System 2008-12-21 18:38:03 EST
NetworkManager-0.7.0-0.12.svn4326.fc9, NetworkManager-vpnc-0.7.0-0.11.svn4326.fc9, NetworkManager-openvpn-0.7.0-16.svn4326.fc9, NetworkManager-pptp-0.7.0-0.12.svn4326.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 14 Fedora Update System 2008-12-21 18:42:36 EST
NetworkManager-0.7.0-0.12.svn4326.fc8, NetworkManager-vpnc-0.7.0-0.11.svn4326.fc8, NetworkManager-openvpn-0.7.0-16.svn4326.fc8, NetworkManager-pptp-0.7.0-0.12.svn4326.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.