Bug 353481 - (TAHI-Tracker) TAHI--About IPv6 routing header issue [NEEDINFO]
TAHI--About IPv6 routing header issue
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Irina Boverman
Red Hat Kernel QE team
:
Depends On:
Blocks: 253764 426904
  Show dependency treegraph
 
Reported: 2007-10-25 22:34 EDT by Zhiyong Wu
Modified: 2014-06-03 08:49 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-03 08:49:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
pm-rhel: needinfo? (zwu)


Attachments (Terms of Use)

  None (edit)
Description Zhiyong Wu 2007-10-25 22:34:28 EDT
Description of problem:
  
  When we have tests about "RFC 2460 - IPv6 Specification" by IPv6 test suite 

from TAHI and NUT is set to be the router mode, we found some failing tests
about IPv6 routing header.For more 

detaily information ,please refer to "Additional info".

Reply packet is not right.

Version-Release number of selected component (if applicable):

  kernel-2.6.18-43.el5

Software Environment:   
  
  Testee(NUT):   
    RHEL5 
    Kernel:2.6.18-43.el5 
   
  Tester(TN):   
    FreeBSD6.2 
   
How reproducible:

  every time

Steps to Reproduce:

  1. Configure TAHI test environment.     
  2. Run the TAHI test suite     
  3. After the test completes, check for the results
  
Actual results:

  TN can not receive Echo Reply or forwarded Echo Request from NUT.

Expected results:

  TN can receive Echo Reply or forwarded Echo Request from NUT.

Additional info:

Note: IPv6 Ready Logon Phase-2 and NUT is set to be the router mode.
 
For more information,please refer to

http://focus.brisbane.redhat.com/~zwu/CoreProtocol_router/20071025/Self_Test_1-4-8_p2_router/spec.p2/index.html

(1) 52	Responding to Routing Header - End Node

(2) 53	Unrecognized Routing Type - End Node

(3) 55	Routing Header Reserved Field - End Node

(4) 56	Routing Header Reserved Field - Intermediate Node (Routers Only)

(5) 57	Part A: Header Extension Length Odd

(6) 58	Part B: Address[i] is Multicast

(7) 59	Part A: Header Extension Length Odd

(8) 60	Part B: Segments Left Greater Than Number of Addresses

(9) 63	Part E: Hop Limit = 0.

(10)64	Part F: Hop Limit = 1.

(11)65	Part G: Valid Processing
Comment 1 Zhiyong Wu 2007-10-25 22:38:04 EDT
Also about IPv6 routing header:

  when IPv6 Ready Logon Phase-2 and NUT is set to the host mode,

pls refer to the url below:

http://focus.brisbane.redhat.com/~zwu/CoreProtocol_host/20071024/Self_Test_1-4-8_p2_host/spec.p2/index.html

(1) 38	Responding to Routing Header - End Node

(2) 39	Unrecognized Routing Type - End Node

(3) 40	Routing Header Reserved Field - End Node

(4) 41	Part A: Header Extension Length Odd

(5) 42	Part B: Address[i] is Multicast
Comment 5 Subhendu Ghosh 2007-12-21 01:08:55 EST
RFC 5095 has been approved and RH0 is now considered depracated from supported
standards.

TAHI test suite 1.5.0-b2 (beta) contains an option in config.txt that allows the
test to succeed based on the draft version on RFC 5095. It is expected that the
final release of TAHI Self Test 1.5.0 will follow RFC 5095 guidelines.
Comment 9 Red Hat Bugzilla 2008-07-07 21:24:05 EDT
Adding yshao@redhat.com to the cc list as the manager of the disabled user zwu@redhat.com who reported this bug
Comment 10 RHEL Product and Program Management 2014-03-07 07:40:48 EST
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.
Comment 11 RHEL Product and Program Management 2014-06-03 08:49:44 EDT
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).

Note You need to log in before you can comment on or make changes to this bug.