Bug 35359 - WindowMaker ... /usr/include/WINGs directory is missing ...
WindowMaker ... /usr/include/WINGs directory is missing ...
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: WindowMaker (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Crutcher Dunnavant
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-09 12:09 EDT by jens.koerber
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-18 12:01:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jens.koerber 2001-04-09 12:09:35 EDT
... at least on my system (since 0.64 ??). If so, please apply 
the following patch ... thanks!

--- WindowMaker-0.64.0/WINGs/WINGs/WINGs.h.orig Mon Apr  9 17:13:20 2001
+++ WindowMaker-0.64.0/WINGs/WINGs/WINGs.h      Mon Apr  9 17:13:56 2001
@@ -4,7 +4,7 @@
 #define _WINGS_H_

 #include <wraster.h>
-#include <WINGs/WUtil.h>
+#include <WUtil.h>
 #include <X11/Xlib.h>

 #define WINGS_H_VERSION  20010117
--- WindowMaker-0.64.0/WINGs/WINGs/WINGsP.h.orig        Mon Apr  9 17:14:16
2001
+++ WindowMaker-0.64.0/WINGs/WINGs/WINGsP.h     Mon Apr  9 17:14:28 2001
@@ -6,7 +6,7 @@
 #include <X11/Xutil.h>


-#include <WINGs/WINGs.h>
+#include <WINGs.h>

 #if WINGS_H_VERSION < 20010117
 #error
There_is_an_old_WINGs.h_file_somewhere_in_your_system._Please_remove_it.
Comment 1 Crutcher Dunnavant 2001-04-18 12:01:00 EDT
Ick. I,m not sure which way to fix this, as there /is/ a WINGs dir at lib build
time. Either the header needs to bee fixed, or its install locations need to be
fixed.

Note You need to log in before you can comment on or make changes to this bug.