Bug 35378 - segmentation fault from up2date
Summary: segmentation fault from up2date
Status: CLOSED DUPLICATE of bug 32301
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: up2date   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Preston Brown
QA Contact: Jay Turner
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-04-09 19:18 UTC by Sebastian Bach
Modified: 2015-01-07 23:45 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-10 17:54:24 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Sebastian Bach 2001-04-09 19:18:51 UTC
I'm using kernel 2.2.17-4.
I get a segmentation fault from up2date.
With GNOME I get a Message-Dialog with python segmentation fault.
information.

Reproducible: Always
Steps to Reproduce:
1. up2date -l or up2date -u
	

Actual Results:  >up2date -l
Retrieving list of all available packages...

Removing installed packages from list of updates...
100.0%
Removing packages marked to skip from list...
100.0%
Getting headers for available packages...
100.0%
Removing packages with files marked to skip from list...
segmentation fault (core dumped)
>

Comment 1 Jay Turner 2001-04-09 19:28:09 UTC
Please verify that your versions of rpm and rpm-python are in sync.  Those being
out of sync are the only situations where I have seen seg faults like this.

Comment 2 Sebastian Bach 2001-04-10 17:54:21 UTC
>rpm -q up2date python python-xmlrpc rpm rpm-python
up2date-2.1.7-1
python-1.5.2-27
python-xmlrpc-1.2.1-1
rpm-4.0.2-0.34
rpm-python-4.0.2-0.34

I also tried to reinstall (with rpm -i --force) the packages.
This did not solve the Problem.
I've a recompiled kernel. Perhaps a kernel configuratin Problem?



Comment 3 Preston Brown 2001-04-10 20:10:23 UTC

*** This bug has been marked as a duplicate of 32301 ***

Comment 4 Sebastian Bach 2001-04-11 16:47:20 UTC
After browsing thru the other dep copys I found the fix in 34900.
For convenience I repeat the fix.

Yes, freshing the rpm-python package fixed the up2date error.

   rpm -Fvh rpm-python-4.0.2-7x.i386.rpm

Problem RESOLVED!   Thanks! Sebastian




Note You need to log in before you can comment on or make changes to this bug.