Bug 353841 - Shutdown command after backup won't work
Summary: Shutdown command after backup won't work
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: fwbackups   
(Show other bugs)
Version: 6
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: Stewart Adam
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-10-26 10:12 UTC by David Quinn
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-26 23:05:24 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description David Quinn 2007-10-26 10:12:16 UTC
Description of problem:
I'm trying to get fwbackups to execute the command "shutdown -h now"
after the backup but it doesn't work and my logs show the following error:

Oct 18 19:00:29 :: WARNING : Command returned with a non-zero exit status:
Oct 18 19:00:29 :: ERROR : Return value: 127

The backup is successful but is this a bug or configuration problem?

Version-Release number of selected component (if applicable): 1.43.1

Comment 1 Stewart Adam 2007-10-26 12:26:02 UTC
If I remember correctly, an exit status of 127 is because you're not root when
executing the "shutdown" command. Try using sudo to shutdown the machine (you'll
have to configure /etc/sudoers so that "shutdown" can be run by all users
without a password)

Comment 2 David Quinn 2007-10-26 12:59:50 UTC
Thanks Stuart. The command is executed as root but I think you're right that the
problem may be system related rather than with fw. Thanks for the quick repsonse
and a great programme

Comment 3 Stewart Adam 2007-10-26 23:05:24 UTC
No problem! I'm glad to hear you like it. I'll close the bug as NOTABUG, but if
you find that the problem is occurring from fwbackups feel free to reopen it.


Note You need to log in before you can comment on or make changes to this bug.