This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 353881 - RFE manpage does not describe how to erase a package from a specific architecture
RFE manpage does not describe how to erase a package from a specific architec...
Status: CLOSED UPSTREAM
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: rpm (Show other bugs)
5.0
All Linux
low Severity medium
: ---
: ---
Assigned To: packaging-team-maint
: ManPageChange
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-26 07:05 EDT by Ewald Beekman
Modified: 2013-03-08 06:46 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-08 06:46:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ewald Beekman 2007-10-26 07:05:45 EDT
Description of problem:

If you got for instance both the i386 and the x86_64 version of a package
installed, rpm -qa lists them both with the same name. 
So how to proceed ifyou only want to deinstall the i386 version ?

It turns out that you can append the architecture after the package name,
ie:
[beekman@zero]$ rpm -q zlib
zlib-1.1.4-10.EL3
zlib-1.1.4-10.EL3

[beekman@zero]$ rpm -q zlib --qf '%{NAME}-%{VERSION}-%{RELEASE}-%{ARCH}\n'
zlib-1.1.4-10.EL3-x86_64
zlib-1.1.4-10.EL3-i386

[beekman@zero ~]# rpm -e --test --nodeps zlib
error: "zlib" specifies multiple packages
[beekman@zero ~]# rpm -e --test --nodeps zlib.i386
[beekman@zero ~]# rpm -e --test --nodeps zlib.x86_64
[beekman@zero ~]# rpm -e --test --nodeps zlib-1.1.4-10.EL3.x86_64

this functionality should be added to the manpage.
Comment 1 Florian Festi 2013-03-08 06:46:05 EST
This is more than a bit embarrassing... but RHEL5 has entered development stage 2 ruling RFE out for updates. I at least added the description to the man page in the upstream repository. Thanks for pointing out that this was missing.

Note You need to log in before you can comment on or make changes to this bug.