Bug 35393 - Anaconda dies when using ja_JP.eucJP as lang param in ks.cfg
Anaconda dies when using ja_JP.eucJP as lang param in ks.cfg
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Brent Fox
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2001-04-09 18:57 EDT by mohammed f khan
Modified: 2007-04-18 12:32 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-05-07 16:41:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description mohammed f khan 2001-04-09 18:57:39 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)

Anaconda dies with a a tag not found error during harddisk based ks.cfg 
based install when the lang parameter in ks.cfg is set to ja_JP.eucJP... 
this same parameter works fine during a cd-based install w/ a ks.cfg file. 

Reproducible: Always
Steps to Reproduce:
1.copy redhat cd to a harddisk partition
2.invoke redhat install using loadlin pointing to a ks.cfg (where lang is 
set to ja_JP.eucJP
3.anaconda will crash during install w/ some error in todo.py

Actual Results:  anaconda will crash during install w/ some error in 

Expected Results:  anaconda should have executed successfully and redhat 
7.0j should have been installed on the system w/ japanese as the set 
Comment 1 Brent Fox 2001-04-10 10:21:16 EDT
Please attach the error message.  Otherwise, it's nearly impossible for us to
know exactly where it went wrong.
Comment 2 mohammed f khan 2001-04-10 11:19:50 EDT
Here is the exact error message when anaconda dies:

Traceback (innermost last):
                            File "/usr/bin/anaconda.real", line 435, in ?
                            File "/var/tmp/anaconda-
7.0.1//usr/lib/anaconda/todo.py", line 375, in __init__
                            File "/var/tmp/anaconda-
7.0.1//usr/lib/anaconda/todo.py", line 245, in setByAbbrev
                            KeyError: ja_JP.eucJP
                            install exited abnormally sending termination 
Comment 3 Brent Fox 2001-04-21 19:08:23 EDT
Can you try this with 7.1 and see if the problem still exists?  7.1 has full
Japanese support, whereas 7.0 was split into an English and a Japanese product.
Comment 4 Brent Fox 2001-04-23 15:05:08 EDT
I tried to duplicate this in 7.0J, and I could not.  Things worked just fine for
me...after rebooting, the contents of /etc/sysconfig/i18n are:

I wasn't doing a hard drive install, though...I was doing a cdrom install.
However, this should make no difference.  Can you post the kickstart file you
were using?

Comment 5 Brent Fox 2001-05-07 16:41:06 EDT
Closing due to inactivity.  Please reopen if you have more information.

Note You need to log in before you can comment on or make changes to this bug.