Bug 35398 - /etc/rc.sysinit doesn't honor linuxconf's boot-time profile-choosing mechanism
Summary: /etc/rc.sysinit doesn't honor linuxconf's boot-time profile-choosing mechanism
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: initscripts   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-04-10 00:44 UTC by Dan Rosen
Modified: 2014-03-17 02:20 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-10 00:51:13 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/etc/rc.sysinit, hacked to honor linuxconf profile choices (16.87 KB, text/plain)
2001-04-10 00:49 UTC, Dan Rosen
no flags Details

Description Dan Rosen 2001-04-10 00:44:49 UTC
Linuxconf claims (in confver.help) that passing "PROFILE=<profile-name>" to
the kernel, in LILO, for example, allows users to select which system
profile they want to use at boot time. This is useful, for example, for
laptop users who have different network connectivity at home and at work.

EXPECTED/ACTUAL: Redhat Linux 7.0 does not honor this mechanism, but it should.

I have this working on my machine: I hacked /etc/rc.sysinit to scan
/proc/cmdline for the profile (as specified above) and pass that to
"linuxconf --selectprofile". I had to change the order of certain things
init'ed in that file: linuxconf has dependencies on libs outside my boot
partition, and the hostname and network info depends on linuxconf, so I had
to move the profile selection and host info all below the disk mounting...

I'll attach my hacked-up version of /etc/rc.sysinit to this bug.

Comment 1 Dan Rosen 2001-04-10 00:49:16 UTC
Created attachment 15024 [details]
/etc/rc.sysinit, hacked to honor linuxconf profile choices

Comment 2 Dan Rosen 2001-04-10 00:51:09 UTC
note on the attachment, i didn't actually do all the grep-fu for
"PROFILE=<...>", i just grepped for "home" in the linux commandline. that would
obviously need to change.

Comment 3 Bill Nottingham 2001-08-09 05:22:14 UTC
Since linuxconf has been deprecated, this feature probably won't be added.


Note You need to log in before you can comment on or make changes to this bug.