Bug 354321 - Showing amazon.com HTML emails takes a long time
Showing amazon.com HTML emails takes a long time
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
7
All Linux
low Severity medium
: ---
: ---
Assigned To: Milan Crha
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-26 11:48 EDT by Lauri Nurmi
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-13 04:44:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Amazon HTML email ad that loads very slowly in Evolution (20.93 KB, application/octet-stream)
2007-10-26 19:08 EDT, Lauri Nurmi
no flags Details
proposed gtkhtml patch (522 bytes, patch)
2007-11-12 10:54 EST, Milan Crha
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 435620 None None None Never

  None (edit)
Description Lauri Nurmi 2007-10-26 11:48:09 EDT
Description of problem:
Selecting and showing an HTML email from amazon.com takes something like 30 to
60 seconds on my AMD Sempron 2500+, with CPU usage at ~100% during that time.

There is no obvious reason for this; the emails are not particularly long, nor 
have particularly many images.

The situation has not always been like this.  At some point, about a year ago,
something in Amazon's emails changed and they became painfully slow to load in
Evolution. (The old emails are still quick to load.)

Version-Release number of selected component (if applicable):


How reproducible:
Every time.

Steps to Reproduce:
1. Subcsribe to receive amazon.com email ads.
2. View them in Evolution.
3. Wait.
  
Actual results:


Expected results:


Additional info:
Comment 1 Matthew Barnes 2007-10-26 12:36:30 EDT
Can you attach a sample email as an mbox file so I can import it to try to
reproduce the delay?  Sanitize the contents of the email as necessary.
Comment 2 Lauri Nurmi 2007-10-26 19:08:27 EDT
Created attachment 239711 [details]
Amazon HTML email ad that loads very slowly in Evolution

My personal email addresses changed to myaddress@something.example and
myotheraddress@elsewhere.example. Otherwise intact.
Comment 3 Matthew Barnes 2007-10-26 21:39:03 EDT
Thanks, I can reproduce this somewhat.  Only takes about 5 to 10 seconds on my
machine with Evolution 2.12.1, which is half as fast as yours.
Comment 4 Milan Crha 2007-11-12 10:54:42 EST
Created attachment 255371 [details]
proposed gtkhtml patch

for gtkhtml;

with this patch, it takes only a little time to display, and i didn't realize
any visual difference between the time before and after patch, maybe it can be
patched in this way. (The patch is without ChangeLog entry and so on because
the gnome's bugzilla is down today).
Comment 5 Milan Crha 2007-11-13 04:44:35 EST
Moving this upstream where we will continue to track the problem.
Please see [1] for further updates.

[1] http://bugzilla.gnome.org/show_bug.cgi?id=435620

Note You need to log in before you can comment on or make changes to this bug.