Bug 354391 - rgmanager fix: magmamsg doesn't work if route is incorrect
rgmanager fix: magmamsg doesn't work if route is incorrect
Status: CLOSED ERRATA
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: rgmanager (Show other bugs)
4
All Linux
low Severity low
: ---
: ---
Assigned To: Lon Hohberger
Cluster QE
: ZStream
Depends On: 298831
Blocks: 362651
  Show dependency treegraph
 
Reported: 2007-10-26 12:20 EDT by Lon Hohberger
Modified: 2009-04-16 16:35 EDT (History)
2 users (show)

See Also:
Fixed In Version: RHBA-2007-1000
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-21 16:53:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Small patch to make rgmanager work with prerouting patch for magma (2.17 KB, patch)
2007-10-26 12:20 EDT, Lon Hohberger
no flags Details | Diff

  None (edit)
Description Lon Hohberger 2007-10-26 12:20:45 EDT
+++ This bug was initially created as a clone of Bug #298831 +++

Description of problem:

If multiple IP addresses are bound to the same interface on the same subnet as
the primary cluster communications path, an incorrect routing configuration will
cause magmamsg (and therefore, other applications like rgmanager and ccsd) to
not function correctly.

For example:

   eth0   192.168.78.1
   eth0:1 192.168.78.10

If the cluster's hostname resolves to 192.168.78.1 - but the kernel routes
packets via the 192.168.78.0/24 subnet out via .10, the other members of the
cluster will deny the connection because .10 is does not match a cluster
member's IP address.
Comment 1 Lon Hohberger 2007-10-26 12:20:45 EDT
Created attachment 239301 [details]
Small patch to make rgmanager work with prerouting patch for magma
Comment 6 errata-xmlrpc 2007-11-21 16:53:23 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-1000.html

Note You need to log in before you can comment on or make changes to this bug.