Bug 354411 - RFE: Allow a cluster mirror to be resynced while active
RFE: Allow a cluster mirror to be resynced while active
Status: CLOSED WONTFIX
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: cmirror (Show other bugs)
4
All Linux
low Severity low
: ---
: ---
Assigned To: Jonathan Earl Brassow
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-26 12:25 EDT by Corey Marthaler
Modified: 2010-01-11 21:04 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-30 17:32:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Corey Marthaler 2007-10-26 12:25:26 EDT
Description of problem:
Currently, you can not resync an active cluster mirror even though you can with
a single node mirror. 

[root@grant-01 ~]# lvchange --resync -y mirror_sanity/resync_regular
  Error locking on node grant-01: Volume is busy on another node
  Can't get exclusive access to clustered volume resync_regular


Version-Release number of selected component (if applicable):
2.6.9-63.ELsmp
cmirror-kernel-2.6.9-38.3
Comment 1 Corey Marthaler 2008-07-01 10:54:12 EDT
Setting the flags, maybe we can get this one in, or just close it out.
Comment 2 Jonathan Earl Brassow 2009-02-25 14:52:19 EST
corey, can you do this in rhel5?
Comment 3 Corey Marthaler 2009-03-12 17:25:42 EDT
Jon, this can not be done in RHEL5 currently, cloning BZ...
Comment 4 Corey Marthaler 2009-03-12 17:28:47 EDT
Jon, I take that back, It appears that it can be done (see BZ 463775). It may have failed for me because I'm running multipath.
Comment 5 Jonathan Earl Brassow 2009-03-30 17:32:22 EDT
It's possible this feature could be pulled in as a result of LVM2 updates to RHEL5.x, but we're not going to move on this for rhel4.

Note You need to log in before you can comment on or make changes to this bug.