This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 354531 - script failure
script failure
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: bluez-utils (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: David Woodhouse
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F8Blocker
  Show dependency treegraph
 
Reported: 2007-10-26 13:36 EDT by Bill Nottingham
Modified: 2014-03-16 23:11 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-30 18:34:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2007-10-26 13:36:11 EDT
Description of problem:

  Updating  : bluez-utils                  ####################### [ 5/18] 
error: %post(bluez-utils-3.20-3.fc8.x86_64) scriptlet failed, exit status 1
Comment 1 Bastien Nocera 2007-10-26 15:51:03 EDT
Which bit is it failing? I don't see anything wrong with the scripts...
Comment 2 Bill Nottingham 2007-10-26 16:11:04 EDT
Not sure. If I force it now, it works. I suspect it's the condrestart stuff
(which should be in %postun and be "$1" -ge "1")
Comment 3 Jeremy Katz 2007-10-28 14:10:29 EDT
Yeah, you can definitely get an exit status of 1 there.  If the condrestart bits
aren't hit, then the exit status when the scriptlet exits will be 1.  So the
condrestart probably needs to be moved to %postun, have notting's fix and also
add an exit 0 to the end
Comment 4 Jeremy Katz 2007-10-28 15:57:19 EDT
Fixed to follow the scriptlet guidelines better (and merged the changes with the
devel/ branch)
Comment 5 Rahul Sundaram 2007-10-28 18:48:51 EDT
I don't get any scriptlet errors with the latest update. Can I close?
Comment 6 Joe Orton 2007-10-29 04:42:10 EDT
+if [ "$1" -ge "1" ]; then
+       /sbin/service bluetooth condrestart >/dev/null 2>&1
+       /sbin/service dund condrestart >/dev/null 2>&1
+       /sbin/service pand condrestart >/dev/null 2>&1
 fi

this runs the condrestarts on install ($1 == 1) as well as upgrade, which
doesn't seem necessary (though harmless).
Comment 7 Will Woods 2007-10-30 18:34:08 EDT
Yep, can't reproduce anymore. 

Note You need to log in before you can comment on or make changes to this bug.