Bug 354541 - Please add "R CMD javareconf" to the post install script
Summary: Please add "R CMD javareconf" to the post install script
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: R (Show other bugs)
(Show other bugs)
Version: 7
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: Tom "spot" Callaway
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-10-26 17:38 UTC by Paul Johnson
Modified: 2011-09-23 08:45 UTC (History)
1 user (show)

Fixed In Version: 2.6.0-3.fc7.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-01 21:20:54 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Paul Johnson 2007-10-26 17:38:06 UTC
This is an RPM enhancement request, not an error per se.

Description of problem:

Java packages don't compile, error says can't compile a simple program with the JNI

Version-Release number of selected component (if applicable):


How reproducible:

always...

Steps to Reproduce:
1. install.packages("rJava")
2.
3.
  
Actual results:

compile fails, says JDK not installed.  IT fails because JDK is not in same
place where R package builder had it.

Expected results:


Additional info:

I went to the JGR package team and asked what is up with this. From them, I've
learned that there is a fix.  There is an undocumented feature. Run

R CMD javareconf

and that lets R find your java compiler and headers.  

I wish you would please add this step to the post install script of the RPM.

Comment 1 Fedora Update System 2007-11-01 21:20:49 UTC
R-2.6.0-3.fc7.1 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.