Bug 354591 - File selection dialog mouse wheel scrolls incorrectly
File selection dialog mouse wheel scrolls incorrectly
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: nedit (Show other bugs)
7
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Jindrich Novy
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-26 13:56 EDT by Duane Clark
Modified: 2013-07-02 19:23 EDT (History)
1 user (show)

See Also:
Fixed In Version: 5.5-12.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-20 12:51:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Duane Clark 2007-10-26 13:56:39 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8.1.5) Gecko/20070727 Fedora/1.1.3-2.fc7 SeaMonkey/1.1.3

Description of problem:
When scrolling in the file selection dialog using the mouse wheel, one click of the mouse wheel makes the selection scroll by one page plus one line. This means some entries in the dialog don't get displayed.

nedit implements mouse wheel scrolling by overriding the translations for various forms of <Btn4Down>,<Btn4Up>. Lesstif apparently decided to add builtin support for mouse wheel scrolling, but they did it by adding the translations to the variations of <Btn4Down>. The effect is that using the scroll wheel causes the list to scroll by the number of lines defined by lesstif, plus the number of lines defined by nedit. Since lesstif by default scrolls by a page minus one line, the additional scrolling by nedit causes the window to scroll too far. 

The fix is to change nedit to use variations of <Btn4Down>, and then when nedit overrides the translations, it will override the default lesstif translations. This will restore normal behavior of nedit. A patch to do this has been posted to the nedit mailing list, though not apparently incorporated into nedit:
http://www.nedit.org/pipermail/develop/2007-September/013492.html


Version-Release number of selected component (if applicable):
nedit-5.5-11

How reproducible:
Always


Steps to Reproduce:
1.Open file selection dialog
2.Scroll either of the lists with the mouse scroll wheel.
3.

Actual Results:


Expected Results:


Additional info:
Comment 1 Jindrich Novy 2007-11-05 04:42:46 EST
Applied patch to fix this, update is comming soon. Thanks.
Comment 2 Fedora Update System 2007-11-09 18:39:10 EST
nedit-5.5-12.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update nedit'
Comment 3 Fedora Update System 2007-11-20 12:51:41 EST
nedit-5.5-12.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 4 Fedora Update System 2007-11-20 13:09:09 EST
nedit-5.5-13.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.