Bug 354781 - yum-skip-broken changes yum's dependency solver even when it's not active
yum-skip-broken changes yum's dependency solver even when it's not active
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F8Blocker
  Show dependency treegraph
 
Reported: 2007-10-26 16:02 EDT by Bill Nottingham
Modified: 2014-03-16 23:11 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-27 10:11:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2007-10-26 16:02:12 EDT
Description of problem:

Take a rawhide box, x86_64 with dbus-libs.{i386,x86_64} and dbus.x86_64
installed. Remove them (you'll have to do this by hand.)

Install dbus.{i386,x86_64} from F7.

Run yum upgrade. (Make sure you're pointed somewhere that has dbus-1.1.2-8.fc8)

'Base' yum properly does the upgrade (installs dbus-libs.{i386,x86_64},
dbus.x86_64.)

If you have yum-skip-broken enabled, even if you don't pass --skip-broken, it
changes the depsolver such that dbus-libs.i386 is not pulled in, and the upgrade
fails.

Version-Release number of selected component (if applicable):

yum-3.2.7-1.fc8
rpm-4.4.2.2-3.fc8
yum-skip-broken-1.1.8-1.fc8
Comment 1 Seth Vidal 2007-10-26 22:28:50 EDT
does your /etc/yum/pluginconf.d/skip-broken.conf have:

check_always = 1

in it?

Comment 2 Bill Nottingham 2007-10-26 23:47:46 EDT
No.

[main]
enabled = 1
check_always = 0
Comment 3 Seth Vidal 2007-10-27 10:11:45 EDT
I can't replicate this and neither can Bill (the reporter) which makes it
unlikely that this is the cause. Closing.

Note You need to log in before you can comment on or make changes to this bug.