Bug 35480 - pcmcia net install fails with 3c574_cs at 10Mbps
pcmcia net install fails with 3c574_cs at 10Mbps
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-10 15:58 EDT by Alexandre Oliva
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-11 00:02:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexandre Oliva 2001-04-10 15:58:06 EDT
Because I haven't got my floppy drive handy, I copied all files in the
pcmciadd.img filesystem into the initrd.img filesystem of pcmcia.img, then
set up that kernel and the modified initrd.img as a boot option from lilo.

The text installer fires up, and I can choose to do an NFS install.  So I
specify the IP address of the machine, apparently the host name is resolved
with a reverse DNS query, because I'm not asked for it.  However, when I
get to the point of mounting the installation image from the NFS server,
which is in the same subnet, the mount fails.

It's not a permission problem, since I can mount the filesystem by hand
when I boot Red Hat Linux 7 on the same machine, with the same IP address.

Switching to the modules screen, I see cardmrg exit()ed, and the 3c574_cs
module apparently failed to negotiate the communication speed (the network
on which it's attached runs on 10Mbps).

Any insights?
Comment 1 Brent Fox 2001-04-10 16:13:54 EDT
I've got a feeling that when you modified the initrd, something is now not
working right with the modules.  If you can find a floppy drive, can you try to
make separate disks for pcmcia.img and pcmciadd.img images.

Even if this is a real problem, it's too late to fix for Florence.
Comment 2 Alexandre Oliva 2001-04-10 16:33:39 EDT
I'll pick the floppy drive at home tonight and give it a try.

Meanwhile, is there any recommended way to merge modules from pcmciadd into a
single initrd?  Note that I didn't replace the existing modules in the `modules'
directory of the initrd.img (doing that would cause the installer to ask for the
pcmcia driver disk, which I couldn't load).  I copied the files into the root of
the initrd filesystem, and this appeared to work for loading modules both from
the `modules' directory and from the root.
Comment 3 Alexandre Oliva 2001-04-11 00:01:56 EDT
Indeed, it worked, after booting from the floppy (actually, booting with the
vmlinuz&initrd.img from pcmcia.img, because it wouldn't boot from my floppy)
then letting it load pcmciadd.img from the floppy drive.

Sorry about the noise.

Note You need to log in before you can comment on or make changes to this bug.