Bug 354991 - why not dejavu-lgc-fonts 2.20. why redundancy
why not dejavu-lgc-fonts 2.20. why redundancy
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: dejavu-lgc-fonts (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Behdad Esfahbod
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-26 20:59 EDT by Alexei Podtelezhnikov
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-31 21:15:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexei Podtelezhnikov 2007-10-26 20:59:57 EDT
F8-devel, as it stands now, contains 
dejavu-lgc-fonts-2.19
dejavu-fonts-2.20

They come from the same source, but the smaller package lags behind.
2.20 was cleaned up, so lgc would be even smaller. Is this a historically high 
risk update?
Comment 1 Nicolas Mailhot 2007-10-27 04:25:54 EDT
dejavu and dejavu-lgc have historically been two different packages built two
different ways and maintained by two different persons. So they've not always
been in sync.

Since both are used as default fonts by a lot of people we've avoided pushing
updates after the last test releases, as people complain in a big way if their
default font was broken. dejavu and dejavu-lgc entered F8T3 with different
levels and therefore will hit F8 with different levels (also most of the fixes
in 2.20 where out of the lgc range)

For F9 dejavu and dejavu-lgc will be built from the same source package so
they'll always be in sync in the future
(http://koji.fedoraproject.org/koji/buildinfo?buildID=22419) I'm not sure if we
want to take the risk of offering 2.21 as a F8 update when it's released.
Comment 2 Alexei Podtelezhnikov 2007-10-31 21:15:16 EDT
Fair enough... closing... 

Note You need to log in before you can comment on or make changes to this bug.