Bug 355071 - sysreport fails if HOME directory doesn't exist
sysreport fails if HOME directory doesn't exist
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: sos (Show other bugs)
5.0
All Linux
low Severity medium
: ---
: ---
Assigned To: Adam Stokes
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-27 02:07 EDT by Arenas Belon, Carlo Marcelo
Modified: 2008-03-03 19:24 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-03 19:24:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Arenas Belon, Carlo Marcelo 2007-10-27 02:07:13 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.13) Gecko/20060513 Fedora/1.0.8-1.1.fc3.1.legacy Firefox/1.0.8

Description of problem:
running sudo /usr/sbin/sysreport failes with "Cannot make temp dir"

Version-Release number of selected component (if applicable):
sysreport-1.4.3-10.el5

How reproducible:
Always


Steps to Reproduce:
1. login into a system using a network account (NIS, krb5, ldap, ADS, ...) that has no local home directory
2. run sysreport as root using sudo
3.

Actual Results:
$ sudo /usr/sbin/sysreport
Password:
Cannot make temp dir


Expected Results:
sysreport generated

Additional info:
the problem is that sysreport relies on the HOME environment pointing to a home directory that can be written into to create a temporary directory.

the use of /tmp or ${TMPDIR} should be used instead
Comment 1 Adam Stokes 2008-03-03 19:24:09 EST
Please use sosreport instead. If problem persists file a new bug against sosreport.

Thanks

Note You need to log in before you can comment on or make changes to this bug.