Bug 3551 - __setfpucw missing from glibc-2.1.1-6
Summary: __setfpucw missing from glibc-2.1.1-6
Status: CLOSED DUPLICATE of bug 3468
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: glibc   
(Show other bugs)
Version: 6.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Cristian Gafton
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-06-17 23:58 UTC by iimura
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-06-18 00:09:08 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description iimura 1999-06-17 23:58:13 UTC
If I execute an application on RedHat 6.0 that was compiled
on a RedHat 5.2, get the following message:
  zeus: error in loading shared libraries:
  zeus: undefined symbol: __setfpucw
Zeus is the name of my aplication program.  I know I need to
recode the floating-point exception routine in RedHat 6.0
but I should be able to run programs compiled on RedHat 5.2
on RedHat 6.0 without any problems.  The binary program for
__setfpucw should be provided by glibc even though new
programs compiled using the new header files provided by
RedHat 6.0 will never use them.  They need to be made
available for programs compiled with earlier versions of
glibc.  The same program compiled with libc5 prior to RedHat
5.0 will run on RedHat 6.0.

Comment 1 Jeff Johnson 1999-06-18 00:09:59 UTC
*** This bug has been marked as a duplicate of 3468 ***


Note You need to log in before you can comment on or make changes to this bug.