Bug 355271 - Konqueror should respect fontconfig aliasing
Konqueror should respect fontconfig aliasing
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: kdebase (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F9Target
  Show dependency treegraph
 
Reported: 2007-10-27 10:51 EDT by Alexei Podtelezhnikov
Modified: 2007-11-30 17:12 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-17 15:16:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 57485 None None None Never

  None (edit)
Description Alexei Podtelezhnikov 2007-10-27 10:51:37 EDT
I tried changing default serif, sans, and mono fonts in konqueror to 
Liberation family. Boy, what an improvement that was especially in appearance 
of popular websites: yahoo, cnn, etc!!!

How about making this default for konqueror for Fedora 8. I would, however, 
like to keep DejaVu family as default for menus/titles/toolbars too. 

How about putting this here
/usr/share/kde-settings/kde-profile/default/share/config/konquerorrc ?

Thanks!
Comment 1 Rex Dieter 2007-10-27 13:37:16 EDT
We'll continue to use what fedora uses as the default for serif, sans, mono.

So, the best approach here, imo, would be to lobby for *those* defaults to be
changed.  Reassigning -> fontconfig

Mind you, there's way more at stake here than just looks e.g. language,
character coverage.
Comment 2 Alexei Podtelezhnikov 2007-10-27 18:05:14 EDT
Firefox *already* uses Liberation family displaying www.yahoo.com, 
www.cnn.com, bbcnews.com, etc., because fontconfig *already* aliases Times New 
Roman, Arial, and Courier to Liberation family 
(/etc/fonts/conf.d/30-aliases-fedora.conf).

So, I am guessing, konqueror is happy to find sans-serif in css, even though 
arial is the first choice there. Firefox attempts to find arial first, trusts 
fontconfig to do so, and succeeds.

I don't know which is best approach, but Firefox now looks so much better than 
konqueror.

As far as unicode coverage goes. Liberation family covers 654 glyphs including 
basic and extended latin, greek, and cyrillic. This is indeed less than ~1500 
in standard MS fonts or DejaVu, but pretty good. 

Maybe, it is too early to switch konqueror to Liberation family by default, 
but I will keep my own new settings. I hope that the availability of these 
MS-metric-compatible fonts will be reflected in the release notes of the 
fedora-kde spin or something.
Comment 3 Nicolas Mailhot 2007-10-28 05:30:01 EDT
(In reply to comment #2)
>
> So, I am guessing, konqueror is happy to find sans-serif in css, even though 
> arial is the first choice there.

And thus it's not a problem in distro font choices but a problem in kde code

> As far as unicode coverage goes. Liberation family covers 654 glyphs including 
> basic and extended latin, greek, and cyrillic. This is indeed less than ~1500 
> in standard MS fonts or DejaVu, but pretty good.

Actually dejavu sans has ~ 5000 glyphs at last count, so there's almost a 10×
difference (and the default has been dejavu lgc sans which is smaller but the
default is likely to change for F9). Not that's the only or most important
factor in the default font choice, but it's one of them.
 
Moreover you can ask for changes/fixes in dejavu and get them a month later,
whereas the whole fedora → red hat → ascender circuit has till to prove it could
treat a single request.

Comment 4 Alexei Podtelezhnikov 2007-10-28 10:48:01 EDT
I am leaning to the same conclusion now. This is a konqueror oversight.

- A website should know better when it requests Arial. Arial should then give 
enough unicode coverage and, most likely, so should Liberation Sans.

- When a page requests Sans rather than Arial, DejaVu is a better choice.

- On an international desktop, DajaVu is better, because of better coverage.

So the current configuration is pretty reasonable. Liberation is a substitute 
for Microsoft fonts and that is it. It is not a universal desktop font. 
Konqueror is wrong ignoring Arial in favor of Sans-serif. The konqueror 
behavior is unlikely to change before KDE4.
Comment 5 Alexei Podtelezhnikov 2007-11-02 14:56:25 EDT
I have been told that konqueror relies on what fc-list returns, and that does
not contain aliases. If it relied on fc-match, that would be better. So
FcFontMatch is the way to go.
Comment 6 Rex Dieter 2007-11-02 15:02:07 EDT
anyone take this issue upstream yet (ie, bugs.kde.org, etc... )?
Comment 7 Alexei Podtelezhnikov 2007-11-02 19:04:27 EDT
I've raised the issue on kde-devel and got acknoledgement from coolo. The best
wat to  deal with it is to bug whoever wrote konqueror font selection, which
works but has to be changed. I haven't filed a bug report yet.
Comment 8 Alexei Podtelezhnikov 2007-11-03 00:22:47 EDT
coolo mentioned this oooold bug
http://bugs.kde.org/show_bug.cgi?id=57485

Comment 9 Alexei Podtelezhnikov 2007-11-17 13:09:05 EST
Vote for the upstream bug! 
http://bugs.kde.org/show_bug.cgi?id=57485
Comment 10 Rex Dieter 2007-11-17 15:16:10 EST
OK, we'll continue to track this upstream.

Note You need to log in before you can comment on or make changes to this bug.