Bug 35534 - dynamic header vanishes intermittently
dynamic header vanishes intermittently
Status: CLOSED CURRENTRELEASE
Product: Red Hat Web Site
Classification: Red Hat
Component: Other (Show other bugs)
current
i386 Linux
high Severity high
: ---
: ---
Assigned To: Tom Lancaster
Web Development
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-10 20:21 EDT by Tom Lancaster
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-11 15:13:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom Lancaster 2001-04-10 20:21:43 EDT
Intermittently, and silently, the dynamic headaer will not show up.
The XMLSub <Apps:header /> is being processed by Apache::ASP, because it is
excluded from the source of the generated page. 
However, it is not replaced by the header html.

This problem is intermittent, and varies in frequency from ~50% to ~10%,
when it is present at all.
Comment 1 Tom Lancaster 2001-04-11 15:13:01 EDT
From Paul Lindner: Usually it means that the XML/RDF didn't parse correctly. 
Restarting the server seems to fix it..  I'd create a special script that dumps
the cached contents of the XML::Simple transformation of the RDF, I bet it comes
up empty.. 

Will investigate. Will also look at updating XML::Simple, if possible.
Comment 2 Tom Lancaster 2001-04-25 15:05:19 EDT
I believe this problem is fixed. Diagnosis involved checking the return from
the eval wrapping the XML::Simple rdf parse. It turned out there was an old rdf
lying around on LIVE tag that didn't parse, but which had been deleted from QA
and HEAD.

Note You need to log in before you can comment on or make changes to this bug.