Bug 355351 - Anaconda Installer can not install Fedora on partition with XFS filesystem
Anaconda Installer can not install Fedora on partition with XFS filesystem
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
i386 Linux
low Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2007-10-27 12:09 EDT by Svetoslav P. Chukov
Modified: 2013-01-09 23:28 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-10-28 15:14:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Error log of Anaconda installer (26.94 KB, text/plain)
2007-10-27 12:30 EDT, Svetoslav P. Chukov
no flags Details

  None (edit)
Description Svetoslav P. Chukov 2007-10-27 12:09:03 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.5; Linux) KHTML/3.5.8 (like Gecko)

Description of problem:
I tried Fedora8 Test3 KDE and GNOME Live CD and wanted to install it with XFS 
filesystem. This filesystem appears in the menu with the available 
filesystems. When the formatting of the partition was started I got error 
message (I will post it in attachment) and the installer just quit.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.Try to install Fedora via Live CD (KDE and GNOME Live CDs)
2.Partition manually your hard drive.
3.Choose XFS filesystem for the / mount point.

Actual Results:
Error message appears when the installer tried to format the partitions.

Expected Results:
Successfully installed operating system with properly working filesystem.

Additional info:
Here are the first few lines with the error message:

anaconda None exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/iutil.py", line 62, in execWithRedirect
    raise RuntimeError, errstr
  File "/usr/lib/anaconda/fsset.py", line 381, in labelDevice
    stderr = "/dev/tty5", searchPath = 1)
  File "/usr/lib/anaconda/fsset.py", line 1476, in labelEntry
    entry.fsystem.labelDevice(entry, chroot)
  File "/usr/lib/anaconda/fsset.py", line 1545, in makeFilesystems
    self.labelEntry(entry, chroot)
  File "/usr/lib/anaconda/packages.py", line 158, in turnOnFilesystems
  File "/usr/lib/anaconda/dispatch.py", line 203, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 126, in gotoNext
  File "/usr/lib/anaconda/gui.py", line 1048, in nextClicked
  File "/usr/lib/anaconda/iw/progress_gui.py", line 67, in renderCallback
  File "/usr/lib/anaconda/gui.py", line 1075, in handleRenderCallback
RuntimeError: Error running xfs_db: No such file or directory

Local variables in innermost frame:
chroot: <function chroot at 0xad0f1ec>
stdout: <open file '/dev/tty5', mode 'w' at 0xaa27020>
errno: 2
stdin: 0
argv: ['-x', '-c', 'label /', '/tmp/sda2']
searchPath: 1
errstr: Error running xfs_db: No such file or directory
stderr: <open file '/dev/tty5', mode 'w' at 0xad30cc8>
msg: No such file or directory
command: xfs_db
root: /
Comment 1 Jesse Keating 2007-10-27 12:18:26 EDT
This is almost certainly because tools like xfsprogs.
Comment 2 Svetoslav P. Chukov 2007-10-27 12:30:45 EDT
Created attachment 240571 [details]
Error log of Anaconda installer

I think this is bug in the second stage of Anaconda. The installer is trying to
execute command "xfs_db" but there is no such a command.
Comment 3 Jesse Keating 2007-10-27 13:10:59 EDT
There is no such command because the package itself isn't on the live media.  My
comment got cut off.  "This is almost certainly because tools like xfsprogs are
not included on the Live media and thus not executable by the installer."
Comment 4 Jeremy Katz 2007-10-28 15:14:47 EDT
Fixed so that we check for the existence of the xfs utilities.  You can
workaround by running 'yum install xfsprogs' before starting your install if you
want to use XFS filesystems.

Note You need to log in before you can comment on or make changes to this bug.