Bug 355431 - Kpowersave needs root access after acpid installed
Kpowersave needs root access after acpid installed
Product: Fedora
Classification: Fedora
Component: kpowersave (Show other bugs)
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Dennis Gilmore
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2007-10-27 14:19 EDT by redhat
Modified: 2008-06-16 22:44 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-06-16 22:44:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description redhat 2007-10-27 14:19:34 EDT
Description of problem:

My initial install of F7 on Dell Latitude D630 had kpowersave working fine.
acpid was not installed at all.

After installing acpid, kpowersave no longer works unless ran as root. 
If I run kpowersave as regular user, it cannot suspend, cannot change CPU
frequency policy, and cannot even report it (the policy is "unknown" in
kpowersave status window). When I run kpowersave under sudo, it sees the policy
as "dynamic", can change it, suspend works too. I can run pm-suspend as regular
user and it works. 

Stopping or even removing acpid does not fix the problem. Some permissions must
have changed somewhere and kpowersave no longer has the access it needs.

Version-Release number of selected component (if applicable):


How reproducible:

After acpid was installed, kpowersave needs root privs, this part is 100%
reproducible. Since I can't "undo" it and revert back to working state, I can't
say whether I can reproduce the change caused by acpid.

Steps to Reproduce:
1. Default install - kpowersave works as user
2. Install acpid - kpowersave needs root access
3. Remove acpid - kpowersave still needs root access
Actual results:

Expected results:

Additional info:
Comment 1 Rex Dieter 2007-10-30 11:35:01 EDT
eww.  I'll see if I can reproduce this.  
Comment 2 Rex Dieter 2007-10-30 11:48:52 EDT
worksforme (as reg user) with acpid installed.

$rpm -q acpid kpowersave
Comment 3 redhat 2007-10-30 12:47:43 EDT
You have acpid installed, is it also running? I noticed that running acpid has
some effect on hal (for example, hald-addon-acpi does not lock /proc/acpi/events
if acpid is running), but since I can't undo the change even by removing acpi I
don't know what is important for the problem.

I could debug some more if I knew what to look for. For example, kpowersave
status window now does not display CPU frequency policy (says "unknown") unless
it runs as root (then it's "dynamic"). Clearly kpowersave does not have
permissions to read the policy from somewhere, but from where? Similarly, I
can't change the policy, I get a failure message. kpowersave probaly tried to
write to something and failed? I can't strace it because it forks itself into
background right away. lsof does not show any "interesting" filed open by
kpowersave, but it's unlikely I can catch it with lsof at just the right moment.
Comment 4 Rex Dieter 2007-10-30 12:53:17 EDT
acpid is running, yes.
I also see CPU freq policy as "dynamic" always (and can't change it fwiw).
Comment 5 Dennis Gilmore 2007-11-07 05:32:23 EST
i have acpid running on my Latitude D820 and i am able  to change between
dynamic and performance.  i am unable to select powersave.  

Im guessing that the bug here lies in hal somewhere  since thats all kpowersave
uses to do its heavy lifting.  im reassinging to hal 
Comment 6 David Zeuthen 2007-11-07 10:34:29 EST
Pretty sure this is not a hal problem.
Comment 7 Andrey Meganov 2007-12-24 11:46:52 EST
I have the same problem. Don't know however, if it is somehow connected with acpid. 

Lenovo T60 with Ati X1400 (ekh). F8 install, kpowersave works only if I am
logged in as root. In other cases all Suspend/Hibernate related options are
"greyed out".

[root@fortice ~]# rpm -q acpid kpowersave

Comment 8 Bug Zapper 2008-05-14 10:53:11 EDT
This message is a reminder that Fedora 7 is nearing the end of life. Approximately 30 (thirty) days from now Fedora will stop maintaining and issuing updates for Fedora 7. It is Fedora's policy to close all bug reports from releases that are no longer maintained. At that time this bug will be closed as WONTFIX if it remains open with a Fedora 'version' of '7'.

Package Maintainer: If you wish for this bug to remain open because you plan to fix it in a currently maintained version, simply change the 'version' to a later Fedora version prior to Fedora 7's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that we may not be able to fix it before Fedora 7 is end of life. If you would still like to see this bug fixed and are able to reproduce it against a later version of Fedora please change the 'version' of this bug. If you are unable to change the version, please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's lifetime, sometimes those efforts are overtaken by events. Often a more recent Fedora release includes newer upstream software that fixes bugs or makes them obsolete. If possible, it is recommended that you try the newest available Fedora distribution to see if your bug still exists.

Please read the Release Notes for the newest Fedora distribution to make sure it will meet your needs:

The process we are following is described here: http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 9 Bug Zapper 2008-06-16 22:44:49 EDT
Fedora 7 changed to end-of-life (EOL) status on June 13, 2008. 
Fedora 7 is no longer maintained, which means that it will not 
receive any further security or bug fix updates. As a result we 
are closing this bug. 

If you can reproduce this bug against a currently maintained version 
of Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.