This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 355481 - xchat fails to start, repeatedly renders server tabs
xchat fails to start, repeatedly renders server tabs
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: gtk2 (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-27 16:50 EDT by Matt Domsch
Modified: 2008-01-05 14:07 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-05 14:07:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
xchat-backtrace.txt (9.88 KB, text/plain)
2007-10-27 16:50 EDT, Matt Domsch
no flags Details

  None (edit)
Description Matt Domsch 2007-10-27 16:50:10 EDT
Description of problem:

xchat-2.8.4-6.fc8 x86_64 on up-to-date rawhide (2 weeks before F8 launch).
xchat starts, but gets stuck infinitely redrawing the server tabs on the right
as it tries to automatically connect to them.  It can't actually connect to the
servers because it's spending all its time redrawing their tab.  gdb backtrace
attached shows it's stuck in a signal loop.  It's fine if I don't autoconnect to
servers on startup (e.g. xchat -a).

Version-Release number of selected component (if applicable):
xchat-2.8.4-6.fc8 x86_64

How reproducible:
always for me

Steps to Reproduce:
1. run xchat -a
2.
3.
  
Actual results:
livelocked repeatedly drawing the server tabs

Expected results:
login and run normally

Additional info:
Comment 1 Matt Domsch 2007-10-27 16:50:10 EDT
Created attachment 240731 [details]
xchat-backtrace.txt
Comment 2 Kevin Kofler 2007-10-27 16:59:02 EDT
That sounds very bad.

If you change the tabs to another position (e.g. at the bottom, or showing as a 
tree), does it still happen?
Comment 3 Kevin Kofler 2007-10-27 17:32:37 EDT
The backtrace makes this look a lot like a GTK+ bug, the only XChat functions 
in it are main and fe_main.
Comment 4 Matt Domsch 2007-10-28 15:39:17 EDT
fwiw, starting xchat with the server/channel list in tree mode seems fine.
Comment 5 Matt Domsch 2008-01-05 14:07:39 EST
I've not experienced this problem again after F8 release.  Closing as
non-reproducable.

Note You need to log in before you can comment on or make changes to this bug.