Bug 355771 - pirut and pup crash after entering root password, generate pirut crashdump (sample attached)
pirut and pup crash after entering root password, generate pirut crashdump (s...
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
7
i686 Linux
low Severity low
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-28 07:15 EDT by Neil Tremble
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-29 10:14:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
pup crashdump (2.13 KB, application/octet-stream)
2007-10-28 07:15 EDT, Neil Tremble
no flags Details

  None (edit)
Description Neil Tremble 2007-10-28 07:15:45 EDT
Description of problem:
Running either pup or pirut causes crashdump. This is on an FC7 system which has
been running since public release, with all updates and near daily pup runs.
I don't think this is a dupe, I saw nothing with similar symptoms in the query
results.

Version-Release number of selected component (if applicable):


How reproducible:
Run either pup or pirut with freshrpms and/or livna in the repo list. This was
working last time I tried (three days ago) and has been for some time.


Steps to Reproduce:
1. Run pup or pirit as normal user
2. Enter administrator password when prompted
3. Curse the crashdump
  
Actual results:
A crashdump message box appears.

Expected results:
A list of available updates should appear.

Additional info:
Removing *both* freshrpms and livna from the repo list resolves the problem, pup
then reports there are no updates available for my system. Not sure that's
right, and updates are now wounded, but at least it's not crashing.

I do use livna and freshrpms (mainly for video drivers and video editing
applications) so I'm wondering why both should suddenly cause this problem.

If the system detects problems with particular repos I believe it should
complain and either try to use the available repos, or display a message
indicating the problem. In this case I was able to determine the cause by
looking at the content of the crashdump popup.

Note that both kyum and yumex complained about freshrpms and linva, but didn't
crash. I guess that means there's a serious issue with those repos, but it also
suggests pup/pirut is fragile.

Thankyou for providing an excellent system. All in all I have very few issues
with FC7, and I'm eagerly awaiting FC8.
Comment 1 Neil Tremble 2007-10-28 07:15:45 EDT
Created attachment 240851 [details]
pup crashdump
Comment 2 Jeremy Katz 2007-10-28 14:17:37 EDT
Can you try the version of pirut available in the updates-testing repository with
  yum --enablerepo=updates-testing update pirut

and see if it resolves your problem?
Comment 3 Neil Tremble 2007-10-29 06:31:16 EDT
As requested I updated pirut from updates-testing, then I added livna and
freshrpms to the repo list and tried to run pup.

Now a dialog is presented with the following message in the details section:
"Cannot retrieve repository metadata (repomd.xml) for repository: livna. Please
verify its path and try again". No crashdump is produced.

That means the updates-testing version of pirut does handle the error in the way
I requested, so the issue may be considered resolved.

Thankyou for the prompt response.

Note You need to log in before you can comment on or make changes to this bug.