Bug 355861 - interpreter_regex should include libexecdir
interpreter_regex should include libexecdir
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: rpmlint (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Ville Skyttä
Fedora Extras Quality Assurance
bzcl34nup
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-28 10:42 EDT by Christopher Stone
Modified: 2008-11-22 11:55 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-31 06:25:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Christopher Stone 2007-10-28 10:42:07 EDT
I have a package which upstream creates an interpreter (basically a modified
python like eggdrop) to be used in a shell script.  This interpreter is not
meant to be executed by users and therefore upstream has decided to place the
binary under libdir.

I was told on #fedora-devel that libexecdir would be a better place to put the
binary, however rpmlint would still need to be modified to allow an interpreter
to exist in libexecdir.

Is there a better place to put binaries which are not meant to be run by users?
rpmlint only checks '^/(usr/)?s?bin/[^/]+$' for interpreters.  Should I put the
interpreter under /usr/bin anyway even though its not meant to be run by a user?
 Should rpmlint be modified to accept libexecdir, or should my package just be a
rare exception to the rule?
Comment 1 Ville Skyttä 2007-10-28 13:36:50 EDT
I suppose adding /usr/libexec/* and maybe /usr/lib*/*/* to the interpreter regex
would be ok.  That'll need to be a Fedora only patch though, it's not
upstreamable because /usr/libexec is not in FHS.

Personally I don't think cluttering /usr/bin with stuff that isn't intended to
be run by users would be a good thing.
Comment 2 Bug Zapper 2008-04-04 10:19:33 EDT
Based on the date this bug was created, it appears to have been reported
during the development of Fedora 8. In order to refocus our efforts as
a project we are changing the version of this bug to '8'.

If this bug still exists in rawhide, please change the version back to
rawhide.
(If you're unable to change the bug's version, add a comment to the bug
and someone will change it for you.)

Thanks for your help and we apologize for the interruption.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.
Comment 3 Bug Zapper 2008-05-13 23:46:27 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Fedora Update System 2008-07-27 03:51:04 EDT
rpmlint-0.84-2.fc9 has been submitted as an update for Fedora 9
Comment 5 Fedora Update System 2008-07-30 16:09:25 EDT
rpmlint-0.84-2.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update rpmlint'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-6871
Comment 6 Fedora Update System 2008-08-07 19:54:46 EDT
rpmlint-0.84-2.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Christopher Stone 2008-08-10 11:54:15 EDT
I'm still getting an error:

# rpmlint poker3d
poker3d.x86_64: E: wrong-script-interpreter /usr/libexec/poker3d/poker3d "/usr/libexec/poker3d/underware"


Is this because it is under /usr/libexec/poker3d instead of just /usr/libexec?
Comment 8 Ville Skyttä 2008-08-11 07:35:25 EDT
Yes.
Comment 9 Christopher Stone 2008-08-11 16:20:32 EDT
Shouldn't the regexp handle subdirs as well?
Comment 10 Ville Skyttä 2008-08-12 09:31:07 EDT
I suppose there's no harm in allowing those too.  What's currently implemented in 0.84 is what was originally requested in this bug and outlined in comment 1, and now upstream svn accepts even more: http://rpmlint.zarb.org/cgi-bin/trac.cgi/changeset/1451
Comment 11 Christopher Stone 2008-08-12 11:59:11 EDT
Looks good, merci beaucoup.
Comment 12 Fedora Update System 2008-10-23 16:54:08 EDT
rpmlint-0.85-1.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/rpmlint-0.85-1.fc9
Comment 13 Fedora Update System 2008-10-24 19:49:18 EDT
rpmlint-0.85-1.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update rpmlint'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-9125
Comment 14 Fedora Update System 2008-10-31 06:24:51 EDT
rpmlint-0.85-2.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 15 Fedora Update System 2008-11-04 12:36:55 EST
rpmlint-0.85-2.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/rpmlint-0.85-2.fc10
Comment 16 Fedora Update System 2008-11-22 11:55:21 EST
rpmlint-0.85-2.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.