Bug 355881 - Fedora repository mirrorlist script generates wrong mirrors for Israeli IPs
Fedora repository mirrorlist script generates wrong mirrors for Israeli IPs
Status: CLOSED CURRENTRELEASE
Product: Fedora Infrastructure
Classification: Retired
Component: other (Show other bugs)
unspecified
All Linux
low Severity low
: ---
: ---
Assigned To: Matt Domsch
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-28 11:07 EDT by Oded Arbel
Modified: 2013-01-09 23:28 EST (History)
5 users (show)

See Also:
Fixed In Version: 20071030
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-30 11:43:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Oded Arbel 2007-10-28 11:07:20 EDT
Description of problem:
The mirrorlist script for the Fedora main repository
(http://mirrors.fedoraproject.org/mirrorlist) has some geo-ip detection that
supposed to generate better mirror selection for users based on their location,
but when queries from Israel it generates a mirror list containing mirrors in
Turkey, Russia, China and Japan, none of which has direct connections to Israel
and as a result updates from Israel are very slow.

Version-Release number of selected component (if applicable):
unknown

How reproducible:
Always

Steps to Reproduce:
1. Try to get a mirror list from the mirrorlist script by overriding the country
code to "il" (use
http://mirrors.fedoraproject.org/mirrorlist?repo=fedora-7&arch=x86_64&country=il
for example)
  
Actual results:
The mirrors returned are all very slow from Israel

Expected results:
List of mirrors that are relevant to an Israeli user

Additional info:
Israel has very good uplinks to the UK and US, so I would expect a mirror list
generated for an Israeli audience to include mirrors from those locations. As
such, unless the user manually adds "country=us" to the mirror list URL in each
YUM repo file, the download speed for updates is around single digit KB/sec -
even with the fastestmirrors plugin, as it has no actual fast mirrors to compare
with.
Comment 1 Mike McGrath 2007-10-29 11:40:15 EDT
This is part of our fallback code recently implemented.  Israel does not have
enough local mirrors to actually generate a list, so it falls back to continent.
 Actual links are not tracked in GeoIP.

From a solution that would work for everyone, what would you have us do?
Comment 2 Bill Nottingham 2007-10-29 11:53:08 EDT
Move Israel to Europe for purposes of continent, maybe?
Comment 3 Oded Arbel 2007-10-29 12:01:51 EDT
Moving Israel to Europe sounds like a solution as most European mirrors are fast
enough from Israel. Grouping by continent sounds like a nice idea on paper, but
outside of Europe and North America (maybe South also) it doesn't make much
sense, especially for Asia which is a really big place (the biggest) and
countries on one side of it are not connected at all to countries on the other
side - Japan and China has much better connectivity to the USA then to anything
else. I'm not sure whats the deal with Turkey - maybe its just one slow mirror.

How do you do continent detection without GeoIP ? If you'd look at the regional
IP registry for Israeli IPs (for example, mine - 192.115.22.33), you'd notice
that its RIPE which serves Europe and the middle east. 
Comment 4 Matt Domsch 2007-10-30 11:43:28 EDT
I've remapped .IL into Europe.  Because Israel has no mirrors, you will get the
mirrorlist for Europe instead.

Note You need to log in before you can comment on or make changes to this bug.