Bug 355891 - libmysqld.so missing, use: --with-embedded-server
libmysqld.so missing, use: --with-embedded-server
Status: CLOSED DUPLICATE of bug 149829
Product: Fedora
Classification: Fedora
Component: mysql (Show other bugs)
All Linux
low Severity low
: ---
: ---
Assigned To: Tom Lane
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2007-10-28 11:35 EDT by Stephen
Modified: 2013-07-02 23:15 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-11-21 16:43:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Stephen 2007-10-28 11:35:39 EDT
The mysql packages do not seem to ship libmysqld.so, the library which allows
embedding the server into another program.

$ mysql_config --libmysqld-libs
-L/usr/lib/mysql -lmysqld -lz -lpthread -lcrypt -lnsl -lm -lpthread -lrt
-L/usr/lib -lssl -lcrypto

$ sudo yum whatprovides /usr/lib/mysql/libmysqld.so
No Matches found

Looks like these options need to be added to configure:


$ rpm -q mysql-libs

Tested this on F7, but I took a peek at the .spec in devel and the flags don't
seem to be there.
Comment 1 Stephen 2007-11-21 16:43:31 EST

*** This bug has been marked as a duplicate of 149829 ***

Note You need to log in before you can comment on or make changes to this bug.