Bug 356041 - Can't connect to AP with WPA-PSK
Can't connect to AP with WPA-PSK
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
i386 Linux
low Severity low
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2007-10-28 17:33 EDT by Ruben Kerkhof
Modified: 2008-03-08 12:15 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-03-08 12:15:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
NetworkManager log (6.75 KB, text/plain)
2007-10-28 17:46 EDT, Ruben Kerkhof
no flags Details
wpa_supplicant logfile (19.23 KB, text/plain)
2007-10-28 17:51 EDT, Ruben Kerkhof
no flags Details
Output from nm-applet when run from terminal as root (3.96 KB, text/plain)
2007-12-04 14:29 EST, Chris Hackmeyer
no flags Details

  None (edit)
Description Ruben Kerkhof 2007-10-28 17:33:28 EDT
Description of problem:

I'm trying to connect to my Airport Express with WPA PSK.
nm-applet keeps asking for my passphrase.
Connecting with wpa_supplicant and the same passphrase works though.

Version-Release number of selected component (if applicable):

[root@localhost ~]# rpm -q NetworkManager
[root@localhost ~]# rpm -q wpa_supplicant
[root@localhost ~]# rpm -q kmod-madwifi
[root@localhost ~]# uname -a
Linux localhost.localdomain #1 SMP Wed Oct 24 21:25:41 EDT 2007
i686 i686 i386 GNU/Linux

How reproducible:
- Connect to wpa wireless network
- after about 10 seconds, nm-applet asks for passphrase again.

I added the output of wpa_passphrase to /etc/wpa_supplicant/wpa_supplicant.conf
and started wpa_supplicant with -c /etc/wpa_supplicant/wpa_supplicant.conf
-iwlan0 -Dwext -d, and it associates fine.

I'll attach the logging output.
Comment 1 Ruben Kerkhof 2007-10-28 17:46:11 EDT
Created attachment 241011 [details]
NetworkManager log
Comment 2 Ruben Kerkhof 2007-10-28 17:51:23 EDT
Created attachment 241031 [details]
wpa_supplicant logfile
Comment 3 Dan Williams 2007-10-28 18:01:55 EDT
Could you provide the output of 'iwlist wlan0 scan' for your AP, obscuring the
BSSID if you like?
Comment 4 Ruben Kerkhof 2007-10-28 18:32:40 EDT
[root@localhost ~]# iwlist wlan0 scan
wlan0     Interface doesn't support scanning.

[root@localhost ~]# iwlist ath0_rename scan

 Cell 03 - Address: 00:14:51:78:01:89
                    Frequency:2.412 GHz (Channel 1)
                    Quality=29/70  Signal level=-66 dBm  Noise level=-95 dBm
                    Encryption key:on
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
                              9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
                              48 Mb/s; 54 Mb/s
                    IE: WPA Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (1) : TKIP
                        Authentication Suites (1) : PSK
Comment 5 Brian Jedsen 2007-10-30 02:11:35 EDT
I was able to get wpa_supplicant working with this
/etc/wpa_supplicant/wpa_supplicant.conf file (psk and ssid edited out)



The option of note is ap_scan=1. When set to 0 or 2 it will not work. After
wpa_supplicant is started I can start NetworkManager again it it will get and ip
Comment 6 Ruben Kerkhof 2007-10-30 16:57:00 EDT
wpa_supplicant standalone works fine, with or without the ap_scan option. It's
the combination of wpa_supplicant with NM that doesn't work.
Comment 7 Dan Williams 2007-11-01 09:27:52 EDT
are you hiding the SSID of your AP?
Comment 8 Ruben Kerkhof 2007-11-01 09:57:18 EDT
No, I'm not.
Comment 9 Brian Jedsen 2007-11-01 12:04:38 EDT
I'm not hiding my ssid, either.
Comment 10 Adam Huffman 2007-11-01 20:37:34 EDT
This problem has re-appeared for me, too (there was a similar situation earlier
on in the F8 development cycle).

I am not hiding my SSID.
Comment 11 Chris Hackmeyer 2007-11-13 23:00:54 EST
Just confirming that the same is happening to me on an x86_64 system (no idea 
if that makes a difference) with a Broadcom 4311 card, so this clearly is not 
unique to any particular card/manufacturer.  Also, a lot of people with 
various cards have reported the same or similar problems on FedoraForums, so 
evidently this is quite a widespread problem.
Comment 12 Chris Hackmeyer 2007-11-15 23:45:21 EST
Actually, I take that back.  I'm no longer having this problem after the 
latest round of updates.
Comment 13 Dan Williams 2007-12-03 12:22:24 EST
Chris, which version of NM are you running?  Which kernel?

If others could report their kernel and NM versions as well, that would be great.
Comment 14 Chris Hackmeyer 2007-12-04 14:29:00 EST
Created attachment 277271 [details]
Output from nm-applet when run from terminal as root
Comment 15 Chris Hackmeyer 2007-12-04 14:30:04 EST
Well, the issue had been resolved (at least for me) but went back to the same 
behavior after the latest round of updates yesterday.  My current NM and 
kernel versions are:

NetworkManager 0.7.0-0.6.6.svn3109

That's what I have now, and it's not working.  Back when things were working, 
I think I had:

NetworkManager 0.7.0-0.6.6.svn3030

The attachment is the output I get from running nm-applet from a terminal (as 
root), trying to enter my wireless router's passkey twice, and then hitting 
cancel on the third try (if that makes any sense).

I'm guessing the line
** (nm-applet:4315): WARNING **: couldn't read 4 bytes from gnome-keyring 
socket: Connection reset by peer
is significant, but what do I know?  I hope that helps in some way.
Comment 16 Chris Hackmeyer 2007-12-04 14:33:09 EST
By the way, I should probably note that I tried downgrading the 
NetworkManager-related packages to the svn3030 version and using the older 
kernel, but this didn't seem to have any effect - it still just kept 
repeatedly asking for my password.
Comment 17 Grosswiler Roger 2008-02-08 06:35:28 EST
Is this bug still open? As i remarked last week, it just concerns wpa, but not 
wpa2, which works fine (even if the bssid is hidden).

Comment 18 Ruben Kerkhof 2008-02-16 08:13:04 EST
I haven't been able to get madwifi (or ath5k) working on my laptop with the
latest kernels, so I can't test this for now.
Comment 19 Ruben Kerkhof 2008-03-03 16:48:40 EST
Ok, I've been able to get madwifi working again. Connecting with wpa-supplicant
works, but nm-applet keeps asking for my password

[ruben@localhost ~]$ uname -r
[ruben@localhost ~]$ rpm -q NetworkManager
[ruben@localhost ~]$ rpm -q madwifi
Comment 20 Ruben Kerkhof 2008-03-08 12:15:36 EST
Somehow everything works now on the latest kernel:

[ruben@localhost ~]$ rpm -q madwifi
[ruben@localhost ~]$ rpm -q NetworkManager
[ruben@localhost ~]$ uname -r
[ruben@localhost ~]$ 

Note You need to log in before you can comment on or make changes to this bug.