Bug 356071 - R errantly provides perl(File::Copy::Recursive), perl(Text::DelimMatch)
Summary: R errantly provides perl(File::Copy::Recursive), perl(Text::DelimMatch)
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: R (Show other bugs)
(Show other bugs)
Version: 7
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: Tom "spot" Callaway
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-10-28 23:54 UTC by Chris Weyl
Modified: 2007-11-30 22:12 UTC (History)
1 user (show)

Fixed In Version: 2.6.0-3.fc7.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-01 21:20:52 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Chris Weyl 2007-10-28 23:54:22 UTC
R gives us a number of perl provides:

perl(File::Copy::Recursive) = 0.31
perl(Text::DelimMatch) = 1.01

This, understandably, confuses apt/yum:

Package perl(File::Copy::Recursive) is a virtual package provided by:
  perl-File-Copy-Recursive 0.35-1.fc7
  R 2.6.0-1.fc7
  R.32bit 2.6.0-1.fc7
You should explicitly select one to install.

Given that these modules are installed by R, but to non-standard directories,
I'm of the opinion they should be filtered.  (Especially when
perl-File-Copy-Recursive works just fine for me :))

Comment 1 Robin Norwood 2007-10-29 16:37:59 UTC
And we might consider filing bugs with upstream to just use the system-provided
versions of those modules unless there's a really good reason not to.

Comment 2 Jason Tibbitts 2007-10-30 20:03:14 UTC
Looks like spot fixed this, but there isn't anything else in the distro that
provides perl(Test::DelimMatch) and so R can't be installed.

Comment 3 Tom "spot" Callaway 2007-10-30 20:23:51 UTC
I fixed that mistake this morning, sorry for the problem.

Comment 4 Fedora Update System 2007-11-01 21:20:46 UTC
R-2.6.0-3.fc7.1 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.