Bug 35635 - stack dump printing with LPRng 3.7.4-22
stack dump printing with LPRng 3.7.4-22
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kdebase (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-11 10:24 EDT by skip gaede
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-09-25 15:47:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description skip gaede 2001-04-11 10:24:11 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.2-0.1.49 i686)


Whenever I send a job to the printer, I get a blank page at the end and a
stack dump at the printer. This happens with RC3 (qa0401). I am seeing it
both at work, where I spool jobs to an NT4 Server (DEClaser 5100, aka LN09)
and at home, where I am printing to an HP LaserJet 4L. The error
information at work is

error name: dictstackunderflow
command:   end
errorinfo: errorinfo not displayable

Reproducible: Always
Steps to Reproduce:
1. lpr -P:lp0 <file>
2.
3.
	

Actual Results:  entire file printed, followed by blank page, followed by
error report

Expected Results:  entire file printed
Comment 1 Crutcher Dunnavant 2001-04-18 11:13:24 EDT
odd.

What does the stack dump look like?

Are sure you mean 'lpr -P:lp0' and not 'lpr -Plp0'?

Can you attach the file out produced by:

	zcat /etc/alchemist/namespace/printconf/local.adl > out

(Youll need to be root to run the above command.)
Comment 2 skip gaede 2001-04-20 04:12:19 EDT
Since submitting the bug, I have done further research. The bug is not in 
LPRng, but in Kwrite, and has already been reported (several times) to KDEbugs. 
KDE bug numbers are 15982, 22899, 14304. I was also wrong about the syntax of 
the lpr command: after hastily submitting the bug report, I tried printing the 
buffer (in Kwrite) to a file instead of a printer. When I tried converting the 
file from Postscript to PDF using ps2pdf, I also got the same stack dump as 
reported in #15982 above.

I'll try to be more careful next time...
Comment 3 Ngo Than 2002-10-17 08:11:48 EDT
It's fixed in current release

Note You need to log in before you can comment on or make changes to this bug.