Bug 356481 - logwatch / perl-DateManip dependency
logwatch / perl-DateManip dependency
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: logwatch (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Ivana Varekova
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-29 10:26 EDT by Ted Rule
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-31 05:01:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ted Rule 2007-10-29 10:26:29 EDT
Description of problem:

logwatch's "range" parameter can potentially make use of "human readable date
ranges". However, this depends on the Date::Manip Perl module. Because logwatch
can run with reduced functionality without the Date::Manip module, the extra
perl-DateManip RPM is not automatically installed as a dependency of logwatch.

Since the perl-DateManip RPM has been available as part of the Core OS for a
long time, it seems reasonable to add:

Requires: perl(Date::Manip)

to logwatch's SPEC file so that the perl-DateManip RPM is installed automatically.




Version-Release number of selected component (if applicable):


How reproducible:

For instance:

$ sudo logwatch --service=iptables --range='since 10/10/2007' --print |more
ERROR: Range "since 10/10/2007" not understood

This system does not have Date::Manip module loaded, and therefore
the only valid --range parameters are 'yesterday', 'today', or 'all'.
The Date::Manip module can be installed by using either of:
   cpan -i 'Date::Manip'
   perl -MCPAN -e 'install Date::Manip'


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Ivana Varekova 2007-10-31 05:01:00 EDT
Fixed in logwatch-7.3.6-10.fc9.

Note You need to log in before you can comment on or make changes to this bug.