Bug 356591 - openarena: -data should be packaged seperately
openarena: -data should be packaged seperately
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: openarena (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Michał Bentkowski
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-29 11:28 EDT by Oliver Falk
Modified: 2008-01-18 10:13 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-18 10:13:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Oliver Falk 2007-10-29 11:28:54 EDT
Is there any reason, why openarena includes the -data as well; Isn't this
noarch? And doesn't it make *much* overhead, when updating simple things like
dist-tag or whatever?
Comment 1 Michał Bentkowski 2007-10-29 13:04:16 EDT
The first version of openarena I packaged contained its source and data in one 
package. Then it was splitted but, unfortunetaly, I was unable to create -data 
subpackage seperately because I was on holiday and people wanted to have this 
package quick.

It looks like there's nothing to change in openarena spec but -data will be 
packaged seperately when new version get released.
Comment 2 Oliver Falk 2007-10-30 05:52:27 EDT
Yes. Spec changes are minimal I think. In openarena.spec you just need to remove
the -data subpackage and in openarena-data.spec you need to remove everything
that is in openarena.spec... Well, you'll need a seperate cvs module for that,
but I think that should be no problem (no extra review or such).

Also -data can be noarch (I think), while openarena.spec is not.
Comment 3 Oliver Falk 2007-10-30 05:53:05 EDT
And of course... Only -data package should have the huge tarball included...
Comment 4 Hans de Goede 2007-12-18 04:29:13 EST
Actually I just took a look at openarena and I wonder why it has its own copy of
ioquake, why not use the one in the quake3 package?

Then the openarena package would contain just the data, a wrapper script and a
.desktop file, and thus could be noarch.

Regards,

Hans
Comment 5 Oliver Falk 2007-12-18 07:43:25 EST
Great idea Hans! Thx for your investigation. It make completely sense to me not
including more or less the same bins twice in different pkgs!

Michał what do you think?

(PS: Michał, how's your name pronounced? The 'ł' normally is more like a
(german) 'w' as far as I know from polish...)
Comment 6 Michał Bentkowski 2007-12-18 12:32:31 EST
(In reply to comment #4)
> Actually I just took a look at openarena and I wonder why it has its own copy 
of
> ioquake, why not use the one in the quake3 package?

This is because, afair, openarena was packaged earlier than quake3.
I hope I'll manage to prepare a new package within a few weeks.

(In reply to comment #5)
> (PS: Michał, how's your name pronounced? The 'ł' normally is more like a
> (german) 'w' as far as I know from polish...)

I can't answer you because I know nothing from German ;) its pronouncation
is something like: MEE-how ['mihɑʊ] :)
Comment 7 Hans de Goede 2007-12-19 05:19:47 EST
(In reply to comment #6)
> (In reply to comment #4)
> > Actually I just took a look at openarena and I wonder why it has its own copy 
> of
> > ioquake, why not use the one in the quake3 package?
> 
> This is because, afair, openarena was packaged earlier than quake3.
> I hope I'll manage to prepare a new package within a few weeks.
> 

Ok,

I've been thinking about maybe adding a Provides: ioquake3, to make clear that
the version of quake3 in the quake3 package is ioquake3, what do you think about
this.

Also if you start using the main package I'll putting the ,desktop and autodl
files for the quake3-demo stuff in a -demo subpackage, so that people installing
openarena don't automatically get the demo application menu entry thrown is as a
bonus. So please keep me posted, then I can make sure the new demo-launcher free
quake3 is ready when the new openarena hits the repo.
Comment 8 Michał Bentkowski 2008-01-06 13:36:04 EST
I described what's wrong with openarena and ioquake3 here:
https://www.redhat.com/archives/fedora-games-list/2008-January/msg00004.html

Let the discussion go on on games-list.
Comment 9 Michał Bentkowski 2008-01-18 10:13:16 EST
Openarena now uses ioquake3.

Note You need to log in before you can comment on or make changes to this bug.