Bug 356861 - g-p-m does not communicate with Nokia 6021
g-p-m does not communicate with Nokia 6021
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-phone-manager (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Linus Walleij
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-29 12:14 EDT by Daniel Qarras
Modified: 2008-03-15 11:40 EDT (History)
1 user (show)

See Also:
Fixed In Version: 0.50-3.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-15 10:25:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Qarras 2007-10-29 12:14:36 EDT
Description of problem:
I've got a Nokia 6021 mobile phone but connecting to it over IrDA with
gnome-phone-manager does not work.

Version-Release number of selected component (if applicable):
gnome-phone-manager-0.20-1.fc8
gnokii-0.6.18-2.fc8

How reproducible:
Always.

Steps to Reproduce:
1. service irda start
2. gnome-phone-manager
3. Notice how nothing happens
  
Actual results:
Device identification seems to work but then the communication is just hanging
forever:

localhost:~> gnome-phone-manager --identify /dev/ircomm0
model: 'Nokia 6021'
localhost:~> gnome-phone-manager                        
** Message: bdaddr 
** Message: New connection device is /dev/ircomm0 (changed)
** Message: New connection device is /dev/ircomm0 (not changed)
** Message: Connecting...
** Message: Status 1
** Message: Making serial port connection


Expected results:
gnome-phone-manager doing what it is supposed to do (I don't know what that is,
it doesn't work for me!)

Additional info:
I've installed gnokii and gnome-phone-manager RPMs and gnokii --monitor once
works all ok so it hints that the problem is in gnome-phone-manager.

If you need more info/logs/traces, please let me know.
Comment 1 Daniel Qarras 2007-10-29 12:17:00 EDT
Relevant parts of /etc/gnokiirc are below:

[global]
port = /dev/ircomm0
model = AT
initlength = default
connection = irda
use_locking = no
serial_baudrate = 19200
smsc_timeout = 10
Comment 2 Daniel Qarras 2007-10-29 12:54:37 EDT
Oh, well, silly me, now I see it there: the correct model is AT not 6021. I
verified this by changing file /usr/share/gnome-phone-manager/phones.xml:

        <phone_entry
                identifier="Nokia 6021"
                driver="AT" />

With the above gnokiirc and the modified phones.xml g-p-m now works! And FWIW,
using AT in both configs was the only combination that worked.

So, please update the file /usr/share/gnome-phone-manager/phones.xml accordingly.
Comment 3 Daniel Qarras 2007-10-30 15:33:27 EDT
Sorry for the noise but I investigated this a bit more: in gnokii sources there
are these special drivers for Nokia models:

gnokii/common/phones/nk2110.c
gnokii/common/phones/nk3110.c
gnokii/common/phones/nk6100.c
gnokii/common/phones/nk6160.c
gnokii/common/phones/nk6510.c
gnokii/common/phones/nk7110.c

So I think by default the driver should be AT and only mobiles requiring a
special driver should be trying something else.
Comment 4 Bastien Nocera 2007-11-27 13:16:55 EST
(In reply to comment #3)
<snip>
> So I think by default the driver should be AT and only mobiles requiring a
> special driver should be trying something else.

That's already what it does, and we actually connect twice to phones. The first
time to check the model of the phone, using the AT driver, then using the proper
driver. In your case, it should be the 6510 driver (or using the alias "6021").

I think your testing was badly made, modifying the phones.xml file will only
make it not connect a second time, it will still connect using the AT driver.

Please retest this using gnome-phone-manager 0.40 as available in F8 and rawhide.
Comment 5 Daniel Qarras 2007-11-27 16:14:54 EST
I now retested both 0.30 and 0.40.

Unmodified 0.30 won't connect. Modified 0.30 with driver AT connects. These are
both as described above. What I now see is that gnokii indeed works with driver
being 6510. 6021 or 6510 in phones.xml does not work, only AT does. I don't know
why. The symptons are as above.

For 0.40 things are different. Not matter what driver is specified in phones.xml
0.40 always says:

root@localhost:~# gnome-phone-manager --identify /dev/ircomm0
Couldn't open PHONET device: Inappropriate ioctl for device

** (gnome-phone-manager:3115): WARNING **: gn_gsm_initialise: Command failed

** (gnome-phone-manager:3115): WARNING **: Couldn't connect to the
'/dev/ircomm0' phone: No reason
root@localhost:~# 

This on Fedora 8 with all latest updates, otherwise the system is all the same
for 0.30/0.40, only the gnome-phone-manager RPM is updated. Should I file
another bug about this?
Comment 6 Bastien Nocera 2007-11-27 17:23:00 EST
Do you get the same error message using the following config file, running
"gnokii --identify"?

[global]
port = /dev/ircomm0
model = AT
initlength = default
connection = serial

Notice the different connection.

Also note that changing the driver in the phones.xml for your phone will make
absolutely no difference for gnome-phone-manager, as the first connection is
_always_ made using the AT driver.
Comment 7 Daniel Qarras 2007-11-28 11:20:27 EST
With the config above I see no errors:

root@localhost:~# file .gnokiirc
.gnokiirc: ERROR: cannot open `.gnokiirc' (No such file or directory)
root@localhost:~# cat /etc/gnokiirc
[global]
port = /dev/ircomm0
model = AT
initlength = default
connection = serial
root@localhost:~# gnokii --identify
GNOKII Version 0.6.18
IMEI         : xxxxxxxxxxxxxxxxxxxx
Manufacturer : Nokia
Model        : Nokia 6021
Product name : Nokia 6021
Revision     : V 04.50
root@localhost:~# 
Comment 8 Daniel Qarras 2007-12-29 11:17:39 EST
Any news with this one? I'd be happy to provide more information if needed to
solve this issue. Thanks.
Comment 9 Daniel Qarras 2008-03-06 13:18:34 EST
Hi, any news on this one? I tried latest RPM from rawhide but got the same
results said in Comment #5. Thanks.
Comment 10 Daniel Qarras 2008-03-06 13:48:37 EST
Actually, I have some more information: g-p-m does not communicate with my Nokia
6021 even over a Nokia CA-42 cable:

root@localhost:~# gnome-phone-manager --identify /dev/ttyACM0
Couldn't open PHONET device: Inappropriate ioctl for device

** (gnome-phone-manager:2690): WARNING **: gn_gsm_initialise: Command failed

** (gnome-phone-manager:2690): WARNING **: Couldn't connect to the
'/dev/ttyACM0' phone: No reason
root@localhost:~# 

But again gnokii works all ok. (And wvdial, too).

I'm having same kind of troubles with NetworkManager at Bug 296851, could this
be some issue in a component common to g-p-m and NM, such as glib? (just guessing)

Cheers.
Comment 11 Daniel Qarras 2008-03-10 12:25:34 EDT
Well, the author of NetworkManager thinks that the problem is not in a shared
component so I think we're talking about a genuine g-p-m bug here :)

http://mail.gnome.org/archives/networkmanager-list/2008-March/msg00123.html
Comment 12 Daniel Qarras 2008-03-11 13:05:09 EDT
Still the same issue with 0.50 from rawhide.
Comment 13 Bastien Nocera 2008-03-14 14:03:24 EDT
Please test gnome-phone-manager-0.50-3.fc9.
Comment 14 Daniel Qarras 2008-03-15 10:19:57 EDT
I didn't find gnome-phone-manager-0.50-3.fc9 from rawhide (even from redhat.com)
so I built from source and it worked! Thanks!
Comment 15 Bastien Nocera 2008-03-15 10:25:46 EDT
Wicked. Let's close this then.

The build is here, if you want to use official RPMs instead.
http://koji.fedoraproject.org/koji/buildinfo?buildID=42910
Comment 16 Daniel Qarras 2008-03-15 11:40:23 EDT
Thanks for the link, I can confirm that the connection works also with the RPM.

Note You need to log in before you can comment on or make changes to this bug.