Bug 356931 - gnome-keyring-pam not working
gnome-keyring-pam not working
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-keyring (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Tomáš Bžatek
Fedora Extras Quality Assurance
: Reopened
Depends On: 250147 312531 441225 441226
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-29 12:51 EDT by Mads Villadsen
Modified: 2015-03-03 17:31 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-14 17:29:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mads Villadsen 2007-10-29 12:51:14 EDT
Description of problem:
Even though I have set my keyring password to be the same as my login password I
still have to enter it twice (once at the gdm prompt and again the first time I
have to access something in my keyring).

Version-Release number of selected component (if applicable):
[maxx@ice ~]$ rpm -qa | grep gdm
gdm-2.20.1-5.fc8
fedorainfinity-gdm-theme-8.0.1-1.fc8

[maxx@ice ~]$ rpm -qa | grep keyring
gnome-keyring-2.20.1-3.fc8
gnome-keyring-pam-2.20.1-3.fc8
gnome-keyring-devel-2.20.1-3.fc8
gnome-python2-gnomekeyring-2.20.0-1.fc8
Comment 1 Maxime Bellengé 2007-11-10 05:10:43 EST
I have the exact same problem.

I upgraded from F7 to F8 and now evolution keeps asking for the keyring password.

The keyring password is the same as the login password. I checked every thread
on the mailing list, tried everything but it doesn't work.

Comment 2 Maxime Bellengé 2007-11-12 03:35:33 EST
I fixed my problem. The upgrade from F7 to F8 doesn't install pam keyring rpm. I
installed it, added appropriate lines in /etc/pam.d/gdm and now it works fine.
Comment 3 Dawid Zamirski 2007-11-12 14:52:34 EST
(In reply to comment #2)
> I fixed my problem. The upgrade from F7 to F8 doesn't install pam keyring rpm. I
> installed it, added appropriate lines in /etc/pam.d/gdm and now it works fine.

Should't it work without pam_keyring rpm? AFAIK, it should be obsolete as
gnome-keyring-pam should takeover this functionality since GNOME 2.20
Comment 4 Martin Ebourne 2007-11-23 12:18:23 EST
I noticed that gnome-keyring-pam unlocks the 'login' keyring whereas the
applications were using the 'default' keyring. I changed the default to 'login'
and readded the keys but still no joy.
Comment 5 Jonathan Underwood 2007-12-02 15:11:09 EST
Packager AWOL?
Comment 6 Denis Leroy 2007-12-02 18:11:57 EST
No, not AWOL. But as far as I can see, there's nothing broken with pam_keyring
per see. It needs to be installed manually and the lined added to the
/etc/pam.d/gdm, just like for F-7.

As was said, gnome-keyring-pam is supposed to take over, but unlocks the wrong
keyring. Maybe this discussion should be brought over to the mailing list to
discuss whether it's gnome-keyring-pam that needs to change, or
NetworkManager... I'll take a look at the problem now.
Comment 7 Denis Leroy 2007-12-02 18:50:51 EST
gnome-keyring-pam not working seems to be this:

https://bugzilla.redhat.com/show_bug.cgi?id=312531

pam_keyring works here on F-8, so I'm closing this WORKSFORME. As for
pam_keyring not being setup by default, that was a known problem:

https://bugzilla.redhat.com/show_bug.cgi?id=232857
Comment 8 Martin Ebourne 2007-12-02 19:10:17 EST
#312531 appears to have been closed before Fedora 8 shipped, so I don't think
that's it.

The bug title clearly states pam-gnome-keyring not working, and nowhere is
pam-keyring mentioned. I think the bug is just against the wrong component.
Maybe it should be reopened and assigned to the gnome-keyring component, since
it's clearly broken.
Comment 9 Jonathan Underwood 2007-12-02 19:19:56 EST
Well, I think the significant thing in #312531 is that Matthias Clasen disabled
the auot-unlock checkboxes. I wonder if they were ever turned back on (certainly
that is what is missing in F-8).

I agree though, this looks like a gnome-keyring problem.
Comment 10 Jonathan Underwood 2007-12-02 19:21:58 EST
Denis - any idea why it WORKSFORYOU but noone else? Are you running pure F-8, or
some rawhide packages as well?
Comment 11 Denis Leroy 2007-12-02 19:40:51 EST
Martin: you're right!, this is clearly filed against the wrong component. A more
active related bug seems to be:

https://bugzilla.redhat.com/show_bug.cgi?id=250147

Jonathan: yes, the no-autounlock patch is still present in the f-8 srpm. My
setup is working because I'm using pam_keyring, not gnome-keyring-pam.

Reopening and reassigning this bug to gnome-keyring.
Comment 12 Jonathan Underwood 2008-03-26 21:39:40 EDT
Any progress on this bug?
Comment 13 James G. Brown III 2008-04-06 22:48:13 EDT
Any update on this? If there is anything I can do to help please advise. 

- James
Comment 14 Martin Ebourne 2008-04-22 17:20:58 EDT
This is finally working for me on the F9 preview release. Also unlocks the ssh
keys automatically (seems to be integrated through policykit).
Comment 15 Bug Zapper 2008-05-13 23:46:51 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Note You need to log in before you can comment on or make changes to this bug.