Bug 357121 - snmpd filling /var/log/messages with errors
snmpd filling /var/log/messages with errors
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: net-snmp (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jan Safranek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-29 14:27 EDT by Mark Nielsen
Modified: 2008-05-21 11:42 EDT (History)
0 users

See Also:
Fixed In Version: RHBA-2008-0376
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 11:42:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
snmpd.conf (18.31 KB, text/plain)
2007-10-29 14:27 EDT, Mark Nielsen
no flags Details
various other information (6.38 KB, text/plain)
2007-10-29 14:28 EDT, Mark Nielsen
no flags Details
ifcfg-bond0 (90 bytes, application/octet-stream)
2007-11-01 10:34 EDT, Mark Nielsen
no flags Details
ifcfg-bond0:0 (121 bytes, application/octet-stream)
2007-11-01 10:34 EDT, Mark Nielsen
no flags Details
ifcfg-bond1 (90 bytes, application/octet-stream)
2007-11-01 10:35 EDT, Mark Nielsen
no flags Details
ifcfg-bond1.48 (public interface) (127 bytes, application/octet-stream)
2007-11-01 10:35 EDT, Mark Nielsen
no flags Details
ifcfg-bond1.20 (47 bytes, application/octet-stream)
2007-11-01 10:35 EDT, Mark Nielsen
no flags Details
ifcfg-bond1.21 (47 bytes, application/octet-stream)
2007-11-01 10:36 EDT, Mark Nielsen
no flags Details
eth0 (90 bytes, application/octet-stream)
2007-11-01 10:36 EDT, Mark Nielsen
no flags Details
eth1 (90 bytes, application/octet-stream)
2007-11-01 10:36 EDT, Mark Nielsen
no flags Details
eth2 (90 bytes, application/octet-stream)
2007-11-01 10:37 EDT, Mark Nielsen
no flags Details
eth3 (90 bytes, application/octet-stream)
2007-11-01 10:37 EDT, Mark Nielsen
no flags Details
/etc/sysconfig/network (70 bytes, application/octet-stream)
2007-11-01 10:37 EDT, Mark Nielsen
no flags Details

  None (edit)
Description Mark Nielsen 2007-10-29 14:27:50 EDT
Description of problem:
snmpd is filling up /var/log/messages with the following errors, however it is
functioning:

error getting netmask for interface 1
ioctl 35123 returned -1

Version-Release number of selected component (if applicable):
net-snmp-5.3.1-18.el5


How reproducible:
100%

Steps to Reproduce:
1. install rhel5 with net-snmp
2. turn on snmpd 
3. watch /var/log/messages for errors
** I am assuming the errors are related to my complex network, please see the
attached file for information on my network configuration
Actual results:
snmpd spams /var/log/messages but does appear to be running

Expected results:
snmpd doesn't give errors

Additional info: see attached files
Comment 1 Mark Nielsen 2007-10-29 14:27:50 EDT
Created attachment 242261 [details]
snmpd.conf
Comment 2 Mark Nielsen 2007-10-29 14:28:32 EDT
Created attachment 242271 [details]
various other information
Comment 3 Mark Nielsen 2007-10-30 09:38:19 EDT
SELinux is disabled. No snmpd entries exist in audit.log.

Comment 4 Jan Safranek 2007-11-01 06:15:52 EDT
I think I found the reason - net-snmp expects the interface name has 8
characters at maximum. Could you please rename the bond1.148 interface to
something shorter, just to prove my theory? Thanks in advance.
Comment 5 Mark Nielsen 2007-11-01 08:07:25 EDT
I will have to test further whether I can change the interface name or not. I
know I can't change the "148" part, because that is how the VLAN tag is
determined. I attempted to change it to bnd1.148, but got errors about the
device not being present. So, to get around that, I tried to start snmpd on
another cluster's node. This other cluster has bond1.48 as the public interface.
I no longer get the "ioctl 35123 returned -1" error, however I still see the
"error getting netmask for interface 1" error repeated in /var/log/messages. 

Though I am using a different node on a different cluster, the are no
differences in packages/builds. All my nodes/clusters are built from the same
kickstart with only the cluster info, host names, network information changed.
Comment 6 Jan Safranek 2007-11-01 09:10:52 EDT
great, at least something can be fixed. Regarding the second "error getting
netmask for interface 1" message, I am not able to reproduce it. It seems it's
caused by network interface without any IPv6 address. How did you make bond0:0
not having IPv6 address? My bonding interfaces have at least link-scope addresses.

Could you please attach configuration scripts of all your interfaces, if possible?
Comment 7 Mark Nielsen 2007-11-01 10:34:24 EDT
Created attachment 245621 [details]
ifcfg-bond0
Comment 8 Mark Nielsen 2007-11-01 10:34:49 EDT
Created attachment 245631 [details]
ifcfg-bond0:0
Comment 9 Mark Nielsen 2007-11-01 10:35:06 EDT
Created attachment 245641 [details]
ifcfg-bond1
Comment 10 Mark Nielsen 2007-11-01 10:35:35 EDT
Created attachment 245651 [details]
ifcfg-bond1.48 (public interface)
Comment 11 Mark Nielsen 2007-11-01 10:35:57 EDT
Created attachment 245661 [details]
ifcfg-bond1.20
Comment 12 Mark Nielsen 2007-11-01 10:36:14 EDT
Created attachment 245671 [details]
ifcfg-bond1.21
Comment 13 Mark Nielsen 2007-11-01 10:36:38 EDT
Created attachment 245681 [details]
eth0
Comment 14 Mark Nielsen 2007-11-01 10:36:51 EDT
Created attachment 245691 [details]
eth1
Comment 15 Mark Nielsen 2007-11-01 10:37:12 EDT
Created attachment 245701 [details]
eth2
Comment 16 Mark Nielsen 2007-11-01 10:37:29 EDT
Created attachment 245711 [details]
eth3
Comment 17 Mark Nielsen 2007-11-01 10:37:46 EDT
Created attachment 245721 [details]
/etc/sysconfig/network
Comment 18 Jan Safranek 2007-11-01 11:31:11 EDT
Reproducer of "ioctl 35123 returned -1":
have an interface name be longer than 8 characters, e.g. bond1.148

Reproducer of "error getting netmask for interface 1":
have an interface *without* IPv4 address (e.g. bond0 below) and make alias of it
*with* IPv4 address (e.g. bond0:0). It does not matter if the interface is eth0,
tap0 or bond0, important is the alias and the addresses.

bond0     Link encap:Ethernet  HWaddr 00:18:8B:41:12:57  
          inet6 addr: fe80::218:8bff:fe41:1257/64 Scope:Link
          UP BROADCAST RUNNING MASTER MULTICAST  MTU:1500  Metric:1
          ...
bond0:0   Link encap:Ethernet  HWaddr 00:18:8B:41:12:57  
          inet addr:192.168.135.80  Bcast:192.168.135.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MASTER MULTICAST  MTU:1500  Metric:1
Comment 19 RHEL Product and Program Management 2007-11-01 11:34:39 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 21 Jan Safranek 2007-11-05 10:33:56 EST
You can test packages at http://people.redhat.com/jsafrane/bugs/357121/
Please report if it works.
Comment 23 Mark Nielsen 2007-11-16 09:43:32 EST
OK, 5.3.1-20 installed and I see none of the errors in /var/log/messages. Looks
good, Jan, thanks!
Comment 27 errata-xmlrpc 2008-05-21 11:42:00 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0376.html

Note You need to log in before you can comment on or make changes to this bug.