Bug 35713 - Errors raised using SSL with python (up2date)
Errors raised using SSL with python (up2date)
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: python (Show other bugs)
7.0
alpha Linux
medium Severity low
: ---
: ---
Assigned To: Nalin Dahyabhai
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-11 17:26 EDT by Marco Valtas
Modified: 2015-01-07 18:45 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-13 10:36:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marco Valtas 2001-04-11 17:26:19 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.2.17-14cl i686; en-US; 0.8.1)
Gecko/20010326


After an update in up2date(to version v2.1.7), the program can't connect to
the server because an "SSL_connect error".  Stunnel was updated too.
Stunnel to version 3.10-2.

Reproducible: Always
Steps to Reproduce:
1.update up2date to version 2.1.7, build up2date-2.1.7-1
2.update stunnel to version 3.10, build stunnel-3.10-2
3.run up2date -p (or any argument that requires secure connection)

	

Actual Results:  Updating package profile...
Traceback (innermost last):
  File "/usr/sbin/up2date", line 455, in ?
    main()
  File "/usr/sbin/up2date", line 350, in main
    up2date.updatePackageProfile()
  File "/usr/share/rhn/up2date/up2date.py", line 702, in updatePackageProfile
    raise CommunicationError(e.args[0])
up2date.CommunicationError: Error communicating with server.  The message was:
SSL_connect error


Expected Results:  Should performed an update of my profile in the RHN server.
Comment 1 Preston Brown 2001-04-12 17:01:31 EDT
Is this error repeatable?  Does it work if you aren't using stunnel?
Comment 2 Preston Brown 2001-04-12 17:02:13 EDT
when I say repeatable, I mean is it repeatable today?  If it was a transient
server side issue, it has probably been addressed.  If not I need to probe
deeper.
Comment 3 Preston Brown 2001-04-12 17:02:29 EDT
also, what version of python is installed?
Comment 4 Marco Valtas 2001-04-12 18:04:28 EDT
The bug is repeatable any time. I thought was an server problem too, but no.
The python packages are:
python-devel-1.5.2-27
python-xmlrpc-1.2.1-1
python-1.5.2-27

the up2date program worked with the standard installation of RH 7 for alpha
system. But in that time was impossible to update de files cause up2date
couldn't retreive the files because a missing part of the rpm name (alpha). In
that time an up2date update was already available and I updated the files. Since
the update I get this error (SSL error) message.
Comment 5 Jay Turner 2001-04-13 10:00:04 EDT
This is indeed an issue for alphas.  I am able to replicate it in the test lab
and reported it to the openssh guys as an issue to take a look at.  In my
testing, I have found that all SSL activity on the alpha is doing this, so this
is definitely not an up2date issue specifically.
Comment 6 Preston Brown 2001-04-13 10:35:26 EDT
Nalin, Cristian: can you look into the python/openssl combo on alpha, and 
determine what is going wrong?
Comment 7 Phil Copeland 2001-06-04 15:36:21 EDT
Ah ha!
broken code

This was recently fixed (caser of memcpy() being used in a overlapping memory
region)

Nothing to see here anymore

Note You need to log in before you can comment on or make changes to this bug.