Bug 357251 - NetworkManager messes with static ethernet setup
NetworkManager messes with static ethernet setup
Status: CLOSED DUPLICATE of bug 134886
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
i386 Linux
low Severity high
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2007-10-29 16:01 EDT by Linus Torvalds
Modified: 2007-11-30 17:12 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-11-13 11:51:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Linus Torvalds 2007-10-29 16:01:23 EDT
Description of problem:

NetworkManager uses DHCP regardless of network settings

Version-Release number of selected component (if applicable):


How reproducible:

Somewhat. It seems to come and go.

Steps to Reproduce:
1. Use system-config-network to use a static IP address for the wired interface
2. Run NetworkManager
3. See the wired ethernet randomly using DHCP
Actual results:

Laptop connected to some random DHCP address

Expected results:

Laptop should get the IP address I specified

Additional info:

This may or may not have anything to do with the fact that the laptop also has a
wireless interface that is set to DHCP (but not set to enable on bootup!)

Oh, and I'm a KDE user. That has shown bugs that were hidden by Gnome before.
Comment 1 Linus Torvalds 2007-10-29 16:04:02 EDT
Oh, and forgot to credit Dave Jones with the suggestion to just turn off
NetworkManager with

    chkconfig NetworkManager off

which seems to have made my static configuration work fine again.

But if *I* didn't know how to fix this, how would you expect anybody else to
know? Please just fix NetworkManager instead so that it doesn't mess with static
network configurations, even if the network *does* have a DHCP server on it too.
Comment 2 Warren Togami 2007-10-29 16:49:53 EDT
It is in the plans to make NetworkManager handle stuff like static IP's and
multiple network interfaces, hopefully before F9.  The goal for F8 was to redo
the preivously horrible innards of NetworkManager, which is almost done now. 
Another major feature that I heard being discussed is the ability for
NetworkManager to be compatible with ifup/ifdown and
/etc/sysconfig/network-scripts configurations.

Until NetworkManager becomes fully usable in these other ways, Fedora 8's normal
install does not enable NetworkManager service by default.  The exception
however is that it is enabled by default if you installed from a LiveCD.
Comment 3 Dan Williams 2007-10-29 17:10:41 EDT
Most of the code to handle static IPs like you want is already in NM 0.7
snapshots in F8; the remaining bits will land and be integrated over the next
month to 6 weeks and made rock-freaking-solid.  These should be able to get
pushed out as F8 updates as well.
Comment 4 Linus Torvalds 2007-10-29 17:12:58 EDT
Can this bug be assigned to the LiveCD people, so that it doesn't survive? The
LiveCD install is a huge boon (you can fix up issues before installing), but if
it results in an unusable system, then what's the point?

If NetworkManager gets fixed, this may be moot, but if the plan isn't to enable
it by default in the normal install, then it sounds dangerous to make the LiveCD
install be pointlessly totally different.

I can imagine that it makes tons of sense to have NetworkManager enabled on the
LiveCD itself, but that's different from having it enabled in the actual
resulting install..
Comment 5 Dan Williams 2007-10-29 17:18:43 EDT
That's probably reasonable; but I'm not in that loop.  Thoughts, Jeremy?
Comment 6 Jeremy Katz 2007-10-29 17:29:43 EDT
That completely changes the experience we've had for the past couple of releases
which has been quite good for most users. 

The real bug here is that the NetworkManager bits didn't get finished, but one
part (ignoring devices brought up by the system) is there.

There's no good way for the installer to know that NetworkManager is in use on
an installed system and change its behavior accordingly even if we wanted to
(which is a discussion for another time and place :).  Even just doing something
like skipping the network screen (and thus, removing the fact that you think
you're configuring static bits) on live installs isn't good as not all live
images will be set up to use NetworkManager -- it's a build-time decision by the
builder of the images.
Comment 7 Jeremy Katz 2007-10-29 17:31:21 EDT
And actually, the 'network' service should be disabled on the live image and
have to be explicitly enabled to make its settings apply anyway (and has been
that way even in F7).  Is this not the case?
Comment 8 David Wilson 2007-11-09 23:49:58 EST
I found Network Manager had to be turned off to have a server come up with a
static address.  It was going to be quite a problem to drop off the box at the
ISP and make a visit every time the box is rebooted due to eth0 not being
restored to a static IP number after reboot.
Comment 9 Dan Williams 2007-11-13 11:51:25 EST

*** This bug has been marked as a duplicate of 134886 ***

Note You need to log in before you can comment on or make changes to this bug.