Bug 357281 - RFE: please include basic AX.25 support
RFE: please include basic AX.25 support
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-29 16:22 EDT by matti aarnio
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-29 16:54:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description matti aarnio 2007-10-29 16:22:07 EDT
Almost 6 years latter, and AX.25 didn't make it as permanently enabled
loadable module into any mainline product.

+++ This bug was initially created as a clone of Bug #58632 +++
> Description of problem:
> current versions of redhat do not contain amateur radio support,
> at least basic AX.25 and MKISS support would be needed to make it
> possible to use 'packet radio' (needed for the userspace tools
> which use soundcard and serial port to communicate).
> 
...
> 
> -- Additional comment from arjanv@redhat.com on 2002-02-11 12:07 EST --
> done in rawhide kernel

Could it now be possible to enable it in baseline ?
We few odd geeks would like to use RH/Fedora in out workstations/servers, and to
use them to do very strange bits of networking protocols...

This is available as kernel module at SuSE SLES 10.1, and current Debian kernels.

Comparing my current Fedora kernel, SuSE SLES 10.1 kernel, and some 
Debian kernel  (2.5.23, 2.6.16, 2.6.18  in order):

Subdirectories in   /lib/modules/.../kernel/net/  are:

  802             F  S  D
  8021q           F  S  D
  9p              F
  appletalk       F  S  D
  atm             F     D
  ax25               S  D
  bluetooth       F  S  D
  bridge          F  S  D
  core            F  S  D
  dccp            F  S  D
  decnet          F  S  D
  ieee80211       F  S  D
  ipv4            F  S  D
  ipv6            F  S  D
  ipx             F  S  D
  irda            F  S  D
  key             F  S  D
  lapb               S  D
  llc                S  D
  mac80211        F
  netfilter       F  S  D
  netrom             S  D
  rose               S  D
  rxrpc                 D
  rfkill          F  
  sched           F  S  D
  sctp            F  S  D
  sunrpc          F  S  D
  tipc            F     D
  wanrouter       F  S  D
  wireless        F  S
  x25                   D
  xfrm                  D


Comparison is a bit challenged because somewhen before 2.6.23 some of the WLAN
related material got big rearrangement, but nevertheless of the radio amateur
related protocols following are missing:

  AX25, NETROM, ROSE

Comparing distributions it is fairly obvious to see why nobody bothers much
of Fedora with these, and just elects to use Debian when doing anything
related on AX.25.


SuSE has a habit of labeling some modules as "not supported by Novell", which is
mostly fine by me.  It would be fine by me if RH would do similar, but begin to
offer those modules ready for loading.

Let us few hams worry about how to debug the beast via mainline, if need be.
(We few hams, like -- me, DaveM, A.Cox, Tytso, ...   I think Allan did most of
the AX.25 code work.)

Also a few related utilities would need to make it to Fedora distribution (devel
at first), and they too could be of "lesser support status", if need be.
Those utilities definitely will not make it to Fedora before the kernel support
is turned on.
Comment 1 John W. Linville 2007-10-29 16:43:48 EDT
Dave, Chuck, etc, are there any specific objections to this?
Comment 2 Chuck Ebbert 2007-10-29 16:54:57 EDT
Done in F8 and F7:

-# CONFIG_HAMRADIO is not set
+CONFIG_HAMRADIO=y
+CONFIG_AX25=m
+CONFIG_AX25_DAMA_SLAVE=y
+CONFIG_NETROM=m
+CONFIG_ROSE=m
+CONFIG_MKISS=m
+CONFIG_6PACK=m
+CONFIG_BPQETHER=m
+CONFIG_SCC=m
+CONFIG_DMASCC=m
+CONFIG_SCC_DELAY=n
+CONFIG_SCC_TRXECHO=y
+CONFIG_BAYCOM_SER_FDX=m
+CONFIG_BAYCOM_SER_HDX=m
+CONFIG_BAYCOM_PAR=m
+CONFIG_BAYCOM_EPP=m
+CONFIG_YAM=m
Comment 3 Dave Jones 2007-10-29 16:56:24 EDT
No objections whatsoever.   For the utilities though, it'd be great if someone
who actually used/cared about this stuff packaged & maintained them.

http://fedoraproject.org/wiki/PackageMaintainers/Join has a bunch of info.

Note You need to log in before you can comment on or make changes to this bug.