Bug 357471 - Can't start java swing applications on FC8 (Development)
Can't start java swing applications on FC8 (Development)
Status: CLOSED DUPLICATE of bug 301691
Product: Fedora
Classification: Fedora
Component: libX11 (Show other bugs)
rawhide
i686 Linux
low Severity high
: ---
: ---
Assigned To: Søren Sandmann Pedersen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-29 19:44 EDT by Prasad
Modified: 2014-06-18 05:09 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-31 17:55:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Prasad 2007-10-29 19:44:42 EDT
Description of problem:

When I try to start java swing applications, it fails with the following error
message.

java: xcb_xlib.c:52: xcb_xlib_unlock: Assertion `c->xlib.lock' failed.

Version-Release number of selected component (if applicable):

libX11-1.1.3-4.fc8

http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=6532373

Please not that this problem was reported against FC7 as well, and people were
able working around by using old version of X11 library.

I solved this problem in fedora 7 x86_64;

download this:
libX11-1.0.3-8.fc7.i386.rpm

How reproducible:

Fairly easy to reproduce.

Steps to Reproduce:
1. Download the sample
http://examples.oreilly.com/jswing2/code/ch03/ActionExample.java
2. javac -d . ActionExample.java
3. java ActionExample
  

Actual results:

java: xcb_xlib.c:52: xcb_xlib_unlock: Assertion `c->xlib.lock' failed.



Expected results:


Additional info:

Tried with JDK 1.5 and JDK 1.6
Comment 1 Matěj Cepl 2007-10-31 17:55:55 EDT

*** This bug has been marked as a duplicate of 301691 ***

Note You need to log in before you can comment on or make changes to this bug.